Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13005

Default recipients no longer save on configure system page

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Ubuntu
    • Similar Issues:

      Description

      In the "Extended E-mail Notification" section of the "Configure System" page, "Default Recipients" does not save any values any more. I have tried listing the email addresses with spaces as well as commas as delimiters. After adding them and saving the config, when I go back, the list is empty again. This is further confirmed by my not receiving the email when it is sent. Nothing appears in the jenkins log file when I save the recipients so I haven't a clue why this is happening.

        Attachments

          Activity

          andonidelolmo Andoni del Olmo added a comment -

          I've upgraded to the v.2.18

          After that, i keep on getting the following exception in the logs.

          Looks like has something to do with this open issue. (haven't test it myself yet)

          15.03.2012 09:51:23 hudson.model.Descriptor load
          WARNUNG: Failed to load C:\hudson\hudson.plugins.emailext.ExtendedEmailPublisher.xml
          hudson.util.IOException2: Unable to read C:\hudson\hudson.plugins.emailext.ExtendedEmailPublisher.xml
          at hudson.XmlFile.unmarshal(XmlFile.java:160)
          at hudson.model.Descriptor.load(Descriptor.java:772)
          at hudson.plugins.emailext.ExtendedEmailPublisherDescriptor.<init>(ExtendedEmailPublisherDescriptor.java:282)
          at hudson.plugins.emailext.ExtendedEmailPublisher.<clinit>(ExtendedEmailPublisher.java:518)
          at hudson.plugins.emailext.EmailExtensionPlugin.addEmailTriggerPlugin(EmailExtensionPlugin.java:126)
          at hudson.plugins.emailext.EmailExtensionPlugin.start(EmailExtensionPlugin.java:103)
          at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:343)
          at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:332)
          at hudson.PluginManager$2$1$1.run(PluginManager.java:294)
          at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
          at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
          at jenkins.model.Jenkins$5.runTask(Jenkins.java:813)
          at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
          at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          at java.lang.Thread.run(Thread.java:619)
          Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception : java.lang.NullPointerException
          cause-message : null
          class : hudson.plugins.emailext.ExtendedEmailPublisherDescriptor
          required-type : hudson.plugins.emailext.ExtendedEmailPublisherDescriptor
          path : /hudson.plugins.emailext.ExtendedEmailPublisherDescriptor
          line number : 16
          -------------------------------
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
          at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
          at hudson.util.XStream2.unmarshal(XStream2.java:93)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
          at hudson.XmlFile.unmarshal(XmlFile.java:156)
          ... 16 more
          Caused by: java.lang.NullPointerException
          at hudson.diagnosis.OldDataMonitor.report(OldDataMonitor.java:178)
          at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:271)
          at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:181)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
          ... 25 more

          15.03.2012 09:51:23 hudson.util.RobustReflectionConverter doUnmarshal
          WARNUNG: Skipping a non-existent field recipientList
          com.thoughtworks.xstream.converters.reflection.NonExistentFieldException: No such field hudson.plugins.emailext.ExtendedEmailPublisherDescriptor.recipientList
          at com.thoughtworks.xstream.converters.reflection.FieldDictionary.field(FieldDictionary.java:106)
          at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.getFieldType(PureJavaReflectionProvider.java:152)
          at hudson.util.RobustReflectionConverter.determineType(RobustReflectionConverter.java:358)
          at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:230)
          at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:181)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
          at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
          at hudson.util.XStream2.unmarshal(XStream2.java:93)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
          at hudson.XmlFile.unmarshal(XmlFile.java:156)
          at hudson.model.Descriptor.load(Descriptor.java:772)
          at hudson.plugins.emailext.ExtendedEmailPublisherDescriptor.<init>(ExtendedEmailPublisherDescriptor.java:282)
          at hudson.plugins.emailext.ExtendedEmailPublisher.<clinit>(ExtendedEmailPublisher.java:518)
          at hudson.plugins.emailext.EmailExtensionPlugin.addEmailTriggerPlugin(EmailExtensionPlugin.java:126)
          at hudson.plugins.emailext.EmailExtensionPlugin.start(EmailExtensionPlugin.java:103)
          at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:343)
          at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:332)
          at hudson.PluginManager$2$1$1.run(PluginManager.java:294)
          at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
          at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
          at jenkins.model.Jenkins$5.runTask(Jenkins.java:813)
          at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
          at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          at java.lang.Thread.run(Thread.java:619)

          slide_o_mix Alex Earl added a comment -

          Duplicate of JENKINS-11665


            People

            • Assignee:
              Unassigned
              Reporter:
              allenservedio allenservedio
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: