Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13017

"Invalid date" On Jenkins startup after CVS plugin 2.0 upgrade. Changelogs disappear from GUI

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.451
      CentOs
    • Similar Issues:

      Description

      Just tried to upgrade to 2.0. Jenkinks log give exceptions on startup & none of my projects display any changes / change logs.

      Reverting restores change logs.

      Here's a sample stacktrace

      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.commons.beanutils.PropertyUtilsBean.invokeMethod(PropertyUtilsBean.java:2155)
      at org.apache.commons.beanutils.PropertyUtilsBean.setSimpleProperty(PropertyUtilsBean.java:2141)
      at org.apache.commons.beanutils.PropertyUtilsBean.setNestedProperty(PropertyUtilsBean.java:1948)
      at org.apache.commons.beanutils.PropertyUtilsBean.setProperty(PropertyUtilsBean.java:2054)
      at org.apache.commons.beanutils.BeanUtilsBean.setProperty(BeanUtilsBean.java:1015)
      at org.apache.commons.beanutils.BeanUtils.setProperty(BeanUtils.java:456)
      at org.apache.commons.digester.BeanPropertySetterRule.end(BeanPropertySetterRule.java:197)
      at org.apache.commons.digester.Digester.endElement(Digester.java:1130)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:601)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragment
      ScannerImpl.java:1782)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocu
      mentFragmentScannerImpl.java:2938)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentSc
      annerImpl.java:511)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
      at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
      at org.apache.commons.digester.Digester.parse(Digester.java:1631)
      at hudson.scm.CVSChangeLogSet.parse(CVSChangeLogSet.java:113)
      at hudson.scm.CVSChangeLogParser.parse(CVSChangeLogParser.java:43)
      at hudson.scm.CVSChangeLogParser.parse(CVSChangeLogParser.java:38)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:808)
      at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:782)
      at hudson.model.AbstractBuild.hasParticipant(AbstractBuild.java:356)
      at hudson.model.User.getBuilds(User.java:390)
      at hudson.WebAppMain$2$1.doRun(WebAppMain.java:225)
      at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)
      Caused by: java.lang.RuntimeException: Invalid date
      at hudson.scm.CVSChangeLogSet$CVSChangeLog.setDate(CVSChangeLogSet.java:235)
      ... 34 more
      Caused by: java.text.ParseException: Unparseable date: "2012-02-29"
      at java.text.DateFormat.parse(DateFormat.java:337)
      at hudson.scm.CVSChangeLogSet$CVSChangeLog.setDate(CVSChangeLogSet.java:232)
      ... 34 more

        Attachments

          Issue Links

            Activity

            alexlehm Alex Lehmann added a comment -

            fixed in the head version, this should be in the next version

            kohsuke Kohsuke Kawaguchi added a comment -

            Marking as resolved based on the comment.


              People

              • Assignee:
                Unassigned
                Reporter:
                ganncamp G. Ann Campbell
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: