Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13287

Error on apply configuration when changing job name

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Jenkins shows an empty error panel when applying the configuration of a job if the job name was changed in the configuration.

        Attachments

          Issue Links

            Activity

            williamconroy William Conroy added a comment -

            Actually, I think this issue goes deeper - changing my job name through the job configuration screen broke my build. Changing it back refixed the build. It seemed perhaps that the ..../workspace/buildname directory perhaps didn't change over with the name change, so the build was left pointing at the wrong place. I don't have ssh access to the server I am using Jenkins on to confirm...

            sam_giles Sam Giles added a comment -

            I'm seeing this with 1.466. Steps I used to reproduce:

            I have one build named "xyz"
            I create a new build called "xyz-temp"
            I delete "xyz" using the Jenkins interface
            I try to rename "xyz-temp" to "xyz" hit Apply and I get an empty pop up error box, hit "Save" and I get a Failed to Parse Form data error. And the form JSON has an empty key:

            JSON={"":"xyz (Trunk Branch)\n<br/>.............

            woozyking Leo Li added a comment -

            Seeing this in 1.480.2

            mcrysler Matt Crysler added a comment -

            Just upgraded to 1.543 and seeing it there as well.

            jglick Jesse Glick added a comment -

            JENKINS-17401 notes that Apply does not work for job renames; you must use Save. Not clear if there is more to this bug report than that.

            danielbeck Daniel Beck added a comment -

            Closing this after a month without responses to Jesse's comment.

            Anyone: Feel free to reopen if this isn't a duplicate of JENKINS-17401, but please edit this issue to include an explanation how this is different.


              People

              • Assignee:
                Unassigned
                Reporter:
                almorelle Alexis Morelle
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: