Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13394

Jenkins won't start, PerforceToolinstallation NPE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Linux, Jenkins 1.457 and 1.458
    • Similar Issues:

      Description

      Did my regular updating of plugins. Went from 1.3.10 to 1.3.12 for perforce, now Jenkins produces this stack trace in the browser. The only way I can get it to start up completely is to disable the perforce plugin. Backing out to 1.3.10 did not resolve the problem. I think there is something now not right in some config somewhere that is not being corrected on plugin install.

      Help ...

      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:849)
      at jenkins.model.Jenkins.<init>(Jenkins.java:761)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$6.runTask(Jenkins.java:838)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.plugins.perforce.PerforceToolInstallation.onLoaded(PerforceToolInstallation.java:66)
      ... 13 more

        Attachments

          Issue Links

            Activity

            netappbluedevil NetAppBlueDevil added a comment -

            Nope, only NONE is available under source controls.

            I was figuring that something seems corrupted, but I just don't have any idea if anything can be cleaned up or what parts of the .jenkins folder structure needs to be repaired. I'm working to get a day old snapshot back, but taking a bit to do since I'm getting all the workspaces and stuff since i don't know exactly what might be needed.

            rpetti Rob Petti added a comment -

            Yeah that definitely sounds like some sort of corruption. At the very least, SVN should still be listed since it's included with Jenkins.

            You should only have to restore your xml files (ie, jobs/jobname/config.xml). A full workspace restore is probably overkill.

            netappbluedevil NetAppBlueDevil added a comment -

            I seem to be back running after restoring my install, so taking off blocker. Thanks for the attention Rob.

            I think should keep an eye here and see if anyone else runs into upgrade issues. Once I have a more specific Jenkins backup plugin running I'll try again and see if this was just one of those things. But it does seem like there was some error in plugin data upgrade that bit me here, just don't have anything that pinpoints what.

            rpetti Rob Petti added a comment -

            Yeah, the Perforce plugin data format didn't change between 1.3.10 and 1.3.12, so I'm not sure what the issue could have been... I'm glad you got it sorted, in any case!

            ohtake_tomohiro OHTAKE Tomohiro added a comment -

            Will be fixed in 1.462.
            See JENKINS-13448.


              People

              • Assignee:
                rpetti Rob Petti
                Reporter:
                netappbluedevil NetAppBlueDevil
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: