Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13414

Issue while building jenkinsci-pmd-plugin-a16ba49 source code

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: pmd-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      I've customized PMD, so to point my pmd jar I've edit pom.xml of jenkins pmd plugin sourcode and while building getting following error report.

      Problem encountered during annotation processing;
      see stacktrace below for more information.
      java.lang.AssertionError
      at com.sun.tools.apt.mirror.type.TypeMaker.getType(TypeMaker.java:76)
      at com.sun.tools.apt.mirror.declaration.ClassDeclarationImpl.getSuperclass(ClassDeclarationImpl.java:64)
      at org.jvnet.hudson.maven.plugins.hpi.AnnotationProcessorFactoryImpl$1.process(AnnotationProcessorFactoryImpl.ja
      va:50)
      at com.sun.mirror.apt.AnnotationProcessors$CompositeAnnotationProcessor.process(AnnotationProcessors.java:60)
      at com.sun.mirror.apt.AnnotationProcessors$CompositeAnnotationProcessor.process(AnnotationProcessors.java:60)
      at com.sun.tools.apt.comp.Apt.main(Apt.java:454)
      at com.sun.tools.apt.main.JavaCompiler.compile(JavaCompiler.java:258)
      at com.sun.tools.apt.main.Main.compile(Main.java:1102)
      at com.sun.tools.apt.main.Main.compile(Main.java:964)
      at com.sun.tools.apt.Main.processing(Main.java:95)
      at com.sun.tools.apt.Main.process(Main.java:85)
      at org.jvnet.hudson.maven.plugins.hpi.AptCompiler.compileInProcess(AptCompiler.java:63)
      at org.jvnet.hudson.maven.plugins.hpi.AptCompiler.compile(AptCompiler.java:50)
      at org.jvnet.hudson.maven.plugins.hpi.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:486)
      at org.jvnet.hudson.maven.plugins.hpi.CompilerMojo.execute(CompilerMojo.java:111)
      at org.jvnet.hudson.maven.plugins.hpi.AptMojo.execute(AptMojo.java:24)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:55
      6)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.jav
      a:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdResult
      TokenMacro.java:4: package hudson.plugins.analysis.tokens does not exist
      import hudson.plugins.analysis.tokens.AbstractResultTokenMacro;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdResult
      TokenMacro.java:14: cannot find symbol
      symbol: class AbstractResultTokenMacro
      public class PmdResultTokenMacro extends AbstractResultTokenMacro {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\dashboard\Warnin
      gsPriorityGraphPortlet.java:11: package hudson.plugins.view.dashboard does not exist
      import hudson.plugins.view.dashboard.DashboardPortlet;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\dashboard\Warnin
      gsPriorityGraphPortlet.java:20: cannot access hudson.plugins.view.dashboard.DashboardPortlet
      class file for hudson.plugins.view.dashboard.DashboardPortlet not found
      public final class WarningsPriorityGraphPortlet extends AbstractWarningsGraphPortlet {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\dashboard\Warnin
      gsPriorityGraphPortlet.java:64: cannot find symbol
      symbol : class DashboardPortlet
      location: class hudson.plugins.pmd.dashboard.WarningsPriorityGraphPortlet
      public static class WarningsGraphDescriptor extends Descriptor<DashboardPortlet> {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\FixedPmdW
      arningsTokenMacro.java:4: package hudson.plugins.analysis.tokens does not exist
      import hudson.plugins.analysis.tokens.AbstractFixedAnnotationsTokenMacro;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\FixedPmdW
      arningsTokenMacro.java:14: cannot find symbol
      symbol: class AbstractFixedAnnotationsTokenMacro
      public class FixedPmdWarningsTokenMacro extends AbstractFixedAnnotationsTokenMacro {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\dashboard\Warnin
      gsTablePortlet.java:42: cannot find symbol
      symbol : class DashboardPortlet
      location: class hudson.plugins.pmd.dashboard.WarningsTablePortlet
      public static class WarningsPerJobDescriptor extends Descriptor<DashboardPortlet> {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\dashboard\Warnin
      gsNewVersusFixedGraphPortlet.java:64: cannot find symbol
      symbol : class DashboardPortlet
      location: class hudson.plugins.pmd.dashboard.WarningsNewVersusFixedGraphPortlet
      public static class WarningsGraphDescriptor extends Descriptor<DashboardPortlet> {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\PmdReporter.java
      :9: cannot find symbol
      symbol : class HealthAwareReporter
      location: package hudson.plugins.analysis.core
      import hudson.plugins.analysis.core.HealthAwareReporter;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\PmdReporter.java
      :26: cannot find symbol
      symbol: class HealthAwareReporter
      public class PmdReporter extends HealthAwareReporter<PmdResult> {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\PmdMavenResultAc
      tion.java:10: cannot find symbol
      symbol : class MavenResultAction
      location: package hudson.plugins.analysis.core
      import hudson.plugins.analysis.core.MavenResultAction;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\PmdMavenResultAc
      tion.java:22: cannot find symbol
      symbol: class MavenResultAction
      public class PmdMavenResultAction extends MavenResultAction<PmdResult> {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\PmdMavenResultAc
      tion.java:68: cannot find symbol
      symbol : class MavenResultAction
      location: class hudson.plugins.pmd.PmdMavenResultAction
      public Class<? extends MavenResultAction<PmdResult>> getIndividualActionType() {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\NewPmdWar
      ningsTokenMacro.java:4: package hudson.plugins.analysis.tokens does not exist
      import hudson.plugins.analysis.tokens.AbstractNewAnnotationsTokenMacro;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\NewPmdWar
      ningsTokenMacro.java:14: cannot find symbol
      symbol: class AbstractNewAnnotationsTokenMacro
      public class NewPmdWarningsTokenMacro extends AbstractNewAnnotationsTokenMacro {
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdWarnin
      gCountTokenMacro.java:4: package hudson.plugins.analysis.tokens does not exist
      import hudson.plugins.analysis.tokens.AbstractAnnotationsCountTokenMacro;
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdWarnin
      gCountTokenMacro.java:14: cannot find symbol
      symbol: class AbstractAnnotationsCountTokenMacro
      public class PmdWarningCountTokenMacro extends AbstractAnnotationsCountTokenMacro {
      ^
      Note: hudson.plugins.pmd.PmdDescriptor indexed under hudson.Extension
      Note: hudson.plugins.pmd.PmdReporterDescriptor indexed under hudson.Extension
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdResult
      TokenMacro.java:13: not assignable to java.lang.Object
      @Extension(optional = true)
      ^
      Note: hudson.plugins.pmd.dashboard.WarningsPriorityGraphPortlet.WarningsGraphDescriptor indexed under hudson.Extension
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\FixedPmdW
      arningsTokenMacro.java:13: not assignable to java.lang.Object
      @Extension(optional = true)
      ^
      Note: hudson.plugins.pmd.dashboard.WarningsTablePortlet.WarningsPerJobDescriptor indexed under hudson.Extension
      Note: hudson.plugins.pmd.dashboard.WarningsNewVersusFixedGraphPortlet.WarningsGraphDescriptor indexed under hudson.Exten
      sion
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\NewPmdWar
      ningsTokenMacro.java:13: not assignable to java.lang.Object
      @Extension(optional = true)
      ^
      C:\Documents and Settings\ET33783\Desktop\jenkinsci-pmd-plugin-a16ba49\src\main\java\hudson\plugins\pmd\tokens\PmdWarnin
      gCountTokenMacro.java:13: not assignable to java.lang.Object
      @Extension(optional = true)
      ^
      4 errors
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Fatal error compiling

      Embedded error: APT failed: 1
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 52 seconds
      [INFO] Finished at: Wed Apr 11 19:32:35 IST 2012
      [INFO] Final Memory: 47M/112M
      [INFO] ------------------------------------------------------------------------

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Does it compile without your changes? What did you change in the pom? Seems that some dependencies are not picked.

          karthikeya_v karthikeya karthi added a comment -

          It is not working with out any changes also, getting following error.

          [INFO] ------------------------------------------------------------------------
          [ERROR] FATAL ERROR
          [INFO] ------------------------------------------------------------------------
          [INFO] Error building POM (may not be this project's POM).

          Project ID: null:pmd:hpi:3.26-SNAPSHOT

          Reason: Cannot find parent: org.jvnet.hudson.plugins:analysis-pom for project: null:pmd:hpi:3.26-SNAPSHOT for project nu
          ll:pmd:hpi:3.26-SNAPSHOT

          [INFO] ------------------------------------------------------------------------
          [INFO] Trace
          org.apache.maven.reactor.MavenExecutionException: Cannot find parent: org.jvnet.hudson.plugins:analysis-pom for project:
          null:pmd:hpi:3.26-SNAPSHOT for project null:pmd:hpi:3.26-SNAPSHOT
          at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:404)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:272)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
          at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
          at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
          at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
          at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
          Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find parent: org.jvnet.hudson.plugins:analysis-pom
          for project: null:pmd:hpi:3.26-SNAPSHOT for project null:pmd:hpi:3.26-SNAPSHOT
          at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1396)
          at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:823)
          at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.ja
          va:508)
          at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
          at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:604)
          at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:487)
          at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:391)
          ... 12 more
          Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.jvnet.hudson.plugins:analysis-pom' not found in r
          epository: Unable to download the artifact from any repository

          org.jvnet.hudson.plugins:analysis-pom:pom:1.36

          from the specified remote repositories:
          nexus (http://nexus.edb.com/nexus/content/groups/public/)

          for project org.jvnet.hudson.plugins:analysis-pom
          at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:6
          05)
          at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1392)
          ... 18 more
          Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any reposi
          tory

          org.jvnet.hudson.plugins:analysis-pom:pom:1.36

          from the specified remote repositories:
          nexus (http://nexus.edb.com/nexus/content/groups/public/)

          at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
          at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
          at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:5
          58)
          ... 19 more
          Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository
          at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:404)
          at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
          ... 21 more
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 12 seconds
          [INFO] Finished at: Fri Apr 13 11:11:10 IST 2012
          [INFO] Final Memory: 1M/15M
          [INFO] ------------------------------------------------------------------------


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              karthikeya_v karthikeya karthi
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: