Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13467

WARNING: Failed to advertise the service to DNS multi-cast

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: ruby-runtime-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.459 on Linux CentOS 6
    • Similar Issues:

      Description

      WARNING: Failed to advertise the service to DNS multi-cast
      java.net.MalformedURLException
      at java.net.URL.<init>(URL.java:617)
      at java.net.URL.<init>(URL.java:480)
      at java.net.URL.<init>(URL.java:429)
      at hudson.DNSMultiCast.<init>(DNSMultiCast.java:45)
      at jenkins.model.Jenkins.<init>(Jenkins.java:787)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.NullPointerException
      at java.net.URL.<init>(URL.java:522)
      ... 7 more
      Apr 13, 2012 12:25:26 AM hudson.WebAppMain$2 run
      INFO: Jenkins is fully up and running

        Attachments

          Activity

          whren whren added a comment - - edited

          Face the same issue with 1.459 and 1.460 on debian 6.0.4 x64, standalone :

          Launched with -Dhudson.DNSMultiCast.disabled=true

          KO on HTTP_HOST=debian-amd64-chef (which resolve to 127.0.0.1)
          OK on HTTP_HOST=0.0.0.0

          Stacktrace :

          Apr 16, 2012 8:21:02 PM hudson.DNSMultiCast <init>
          WARNING: Failed to advertise the service to DNS multi-cast
          java.net.MalformedURLException
          at java.net.URL.<init>(URL.java:617)
          at java.net.URL.<init>(URL.java:480)
          at java.net.URL.<init>(URL.java:429)
          at hudson.DNSMultiCast.<init>(DNSMultiCast.java:45)
          at jenkins.model.Jenkins.<init>(Jenkins.java:787)
          at hudson.model.Hudson.<init>(Hudson.java:81)
          at hudson.model.Hudson.<init>(Hudson.java:77)
          at hudson.WebAppMain$2.run(WebAppMain.java:217)
          Caused by: java.lang.NullPointerException
          at java.net.URL.<init>(URL.java:522)
          ... 7 more
          Apr 16, 2012 8:21:02 PM hudson.WebAppMain$2 run
          INFO: Jenkins is fully up and running

          sti Sami Tikka added a comment -

          OK, I have now had a chance to look into this. I'm pretty sure this is not a Jenkins bug, but a misconfiguration.

          The Jenkins URL in global configuration is supposed to be a URL and if it is set to "debian-amd64-chef" or "0.0.0.0", they are not valid URLs and thus it is only appropriate that Jenkins should log a warning. As far as I can see from this bug report, the only problem it causes is the warning and a stack trace, which can be easily corrected by entering a valid URL into Jenkins global configuration.

          If I have misinterpreted the situation, please correct me. Otherwise I will close this bug in a few days. Thank you.

          zolzaya Zolzaya Erdenebaatar added a comment - - edited

          Hi, I'm very new to Jenkins. I have same problem. So I'm agree with Sami Tikka. I don't have any idea how to fix it. I need a instruction. I know this is not a right place. But please help me.

          radepal Radosław Palczyński added a comment -

          I also has that problem with 1.460 on Centos 5.5 on clean install from redhat repo and need instruction like @Zolzaya Erdenebaatar

          whren whren added a comment -

          @Sami

          Maybe i express myself in a wrong way, but :

          • No warning/stacktrace with 0.0.0.0
          • Warning/stacktrace with debian-amd64-chef, or localhost or 127.0.0.1

          So If all are not valid how could it work with 0.0.0.0 ?

          saml Samuel Lopez added a comment -

          This is not longer happening after upgrading to the latest LTS


            People

            • Assignee:
              saml Samuel Lopez
              Reporter:
              saml Samuel Lopez
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: