Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13607

certain projects can't send email: javax.mail.MessagingException: Could not connect to SMTP host: mail.recondotech.com, port: 25, response: 421

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: email-ext-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Loss of functionality: emails aren't getting sent out

      Build "Console Output":

      Build step 'Execute shell' marked build as failure
      Emma: looking for coverage reports in the provided path: target/site/emma/coverage.xml
      Sending e-mails to: asloan7@gmail.com
      ERROR: Could not connect to SMTP host: mail.recondotech.com, port: 25, response: 421
      javax.mail.MessagingException: Could not connect to SMTP host: mail.recondotech.com, port: 25, response: 421
      at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1922)
      at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:638)
      at javax.mail.Service.connect(Service.java:295)
      at javax.mail.Service.connect(Service.java:176)
      at javax.mail.Service.connect(Service.java:125)
      at javax.mail.Transport.send0(Transport.java:194)
      at javax.mail.Transport.send(Transport.java:124)
      at hudson.tasks.MailSender.execute(MailSender.java:114)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.cleanUp(MavenModuleSetBuild.java:1012)
      at hudson.model.Run.run(Run.java:1465)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:238)
      Notifying upstream projects of job completion
      Finished: FAILURE

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          I'm unable to reproduce this, please give more information.

          asloan7 Adam Sloan added a comment -

          Possibly a local email issue, will add info if I see it again (can close until then - a bad day)


            People

            • Assignee:
              Unassigned
              Reporter:
              asloan7 Adam Sloan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: