Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13630

TestLink plugin does not update test case execution status correctly

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Using the jenkins-testlink-plugin-tutorial example, the test case is executed correctly and is passed as part of the Jenkins job. Under Test Execution in TestLink the test case Status is reported as Passed yet the Result is still set to "Not Run". See attached screenshot.

        Attachments

          Issue Links

            Activity

            Hide
            kinow Bruno P. Kinoshita added a comment -

            Successfully reproduced the issue. Thanks for reporting. I will debug TestLink and the plug-in to find out whether it is a bug in the plug-in or in the TestLink XML-RPC API.

            Show
            kinow Bruno P. Kinoshita added a comment - Successfully reproduced the issue. Thanks for reporting. I will debug TestLink and the plug-in to find out whether it is a bug in the plug-in or in the TestLink XML-RPC API.
            Hide
            kinow Bruno P. Kinoshita added a comment -

            Hi again, looking at TestLink, I believe this is the standard behaviour. I don't think it is a bug in TestLink either.

            You set the result of a test case, and the page refreshes. Then now it shows you the options to set another result. The combo box doesn't show the last execution status, from what I could understand.

            In case you believe this is a bug, and you can confirm this is the standard behaviour, feel free to file an issue at mantis.testlink.org.

            Thank you!

            Show
            kinow Bruno P. Kinoshita added a comment - Hi again, looking at TestLink, I believe this is the standard behaviour. I don't think it is a bug in TestLink either. You set the result of a test case, and the page refreshes. Then now it shows you the options to set another result. The combo box doesn't show the last execution status, from what I could understand. In case you believe this is a bug, and you can confirm this is the standard behaviour, feel free to file an issue at mantis.testlink.org. Thank you!
            Hide
            kinow Bruno P. Kinoshita added a comment -

            Fixed in 3.1.3

            Show
            kinow Bruno P. Kinoshita added a comment - Fixed in 3.1.3

              People

              • Assignee:
                kinow Bruno P. Kinoshita
                Reporter:
                robertc Robert Campbell
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: