Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13803

PRQA Plugin fails during the publishing phase with NULL pointer exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: prqa-plugin
    • Labels:
      None
    • Environment:
      Master: linux
      Slave: Windows 7
      Jenkins 1.441
    • Similar Issues:

      Description

      PRQA plugin generates reports correctly, but fails during publishing phase.

      At revision 1572
      no change for https://xx/xx since the previous build
      This job will create a report with the following selected parameters:
      QAR selected project file:	Sources\QAC\xx\xx.prj
      QAR selected product:		QAC
      QAR selected report type:	Compliance
      
      Beginning report generation with the following command:
       qaw QAC "Sources\QAC\xx\xx.prj" -maseq "qar %Q %P+ %L+ -po qar::report_type=Compliance\ Report -po qar::project_name=%J -po qar::output_path=c:\_dev\jenkins-int\workspace\xx_QAC -po qar::viewing_program=dummy -po qar::report_format=xhtml" 
      Viewer "dummy" not available, result will not be rendered.
      Generating - Please wait...
      Writing c:\_dev\jenkins-int\workspace\xx_QAC\Compliance Report.xml
      Writing c:\_dev\jenkins-int\workspace\xx_QAC\Compliance Report.xhtml
      Writing c:\_dev\jenkins-int\workspace\xx_QAC\Compliance Report-Main.xhtml
      Finished remote reporting.
      Found report. Attempting to copy Compliance Report.xhtml to artifacts directory: /home/xx/.jenkins/jobs/xx_QAC/builds/2012-05-16_17-11-12/archive
      Attempting to copy report to following target: Compliance Report.xhtml
      Succesfully copied report
      ERROR: Publisher net.praqma.jenkins.plugin.prqa.notifier.PRQANotifier aborted due to exception
      java.lang.NullPointerException
      	at net.praqma.jenkins.plugin.prqa.notifier.PRQANotifier.perform(PRQANotifier.java:240)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:692)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:667)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:645)
      	at hudson.model.Build$RunnerImpl.post2(Build.java:162)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:614)
      	at hudson.model.Run.run(Run.java:1429)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:238)
      Notifying upstream projects of job completion
      Finished: FAILURE
      

      I have tested this using three configurations, all with Jenkins 1.441

      • Single Jenkins web app running on my local machine (Windows 7): it works
      • Master-slave configuration, both on my local machine (Windows 7), slave as a user process: it works
      • Master-slave configuration, master on a Linux box, slave on my local Windows 7 machine (Windows 7), slave as a user process: it does not work and triggers the error above.

      I could try upgrading to a newer Jenkins, but I'd strongly prefer not to unless shown to be essential.
      I'll be happy to provide further logs. Thanks

        Attachments

          Activity

          lars_kruse Lars Kruse added a comment -

          Hi Julian

          We actually got this error report from you via Jason, PRQA. I filed it as https://issues.jenkins-ci.org/browse/JENKINS-13787 but I will close that as a duplicate.

          We tried to get this fix into 1.0.2 as well but we could not reproduce it in our lab. Even when the master was on Linux and the slave was on windows - started with the java web start (which essentially is a user process).

          Hmmm - I'm not suspecting the 1.441 version to really be the issue.

          Actually the stack trace you have given us is helpful, But I believe in this case, we would welcome any relevant logs you can produce.
          Please attach them to a mail and send them to support@praqma.net.

          Cheers

          madsnielsen Mads Nielsen added a comment -

          Hi Julian,

          First of all thanks for trying out our plugin!

          I have another question regarding this issue, were you by any chance selecting 'Improvement' for any of the available metrics? And did the job have any prior failed builds?

          Regards,
          Mads

          madsnielsen Mads Nielsen added a comment -

          Hi Julian,

          We have succesfully reproduced the bug at our local lab. The error occurs if the job has a previous succesful build that was NOT configured as a PRQA projekt. It should be fixed in the next release.

          Regards,
          Mads

          jrequejo Julian Requejo added a comment -

          Hi Mads. Great finding! I did in fact deactivate the plugin during the initial problems, what led to some successful builds without the PRQA info, exactly as you describe. I can confirm that after deleting all successful jobs without PRQA activated, the plugin now works as expected. The problem is easy to workaround now that I know the cause. Thanks

          madsnielsen Mads Nielsen added a comment -

          Fixed in 1.0.3

          jrequejo Julian Requejo added a comment -

          I can confirm that the bug has been fixed with 1.0.3. I have intentionally produced a build with errors, and the plugin is able to ignore its lack of QAC data in subsequent runs. Thanks for the quick fix.


            People

            • Assignee:
              madsnielsen Mads Nielsen
              Reporter:
              jrequejo Julian Requejo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: