Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13844

"Emulate clean checkout by..." does not work with 1.7 subversion repositories

    Details

    • Similar Issues:

      Description

      The update strategy "Emulate clean checkout by..." does not delete files which are not part of the repository although the log reports that a cleanup is performed.

        Attachments

          Issue Links

            Activity

            Hide
            hx_unbanned Linards L added a comment -

            Still happens on 1.492 with svn 1.43.

            System:
            java.vm.version 22.1-b02
            line.separator
            mail.smtp.sendpartial true
            mail.smtps.sendpartial true
            os.arch amd64
            os.name Windows Server 2008 R2 (Datacenter)

            Show
            hx_unbanned Linards L added a comment - Still happens on 1.492 with svn 1.43. System: java.vm.version 22.1-b02 line.separator mail.smtp.sendpartial true mail.smtps.sendpartial true os.arch amd64 os.name Windows Server 2008 R2 (Datacenter)
            Hide
            forderud Fredrik Orderud added a comment - - edited

            The fix has now been released with Subversion plugin 1.44.

            Linards L: Could you please try to upgrade to SVN plugin 1.44, and try to reproduce afterwards?

            Show
            forderud Fredrik Orderud added a comment - - edited The fix has now been released with Subversion plugin 1.44. Linards L: Could you please try to upgrade to SVN plugin 1.44, and try to reproduce afterwards?
            Hide
            hx_unbanned Linards L added a comment -

            Ok. Please update fixVersion field

            Show
            hx_unbanned Linards L added a comment - Ok. Please update fixVersion field
            Hide
            forderud Fredrik Orderud added a comment -

            Agree, but for it appears like the version field(s) aren't properly configured. I receive an "1.44 is not a valid version" error message when attempting to update the field.

            Show
            forderud Fredrik Orderud added a comment - Agree, but for it appears like the version field(s) aren't properly configured. I receive an "1.44 is not a valid version" error message when attempting to update the field.
            Hide
            kutzi kutzi added a comment -

            The version fields in JIRA only have the Jenkins core versions. This is a known limitation of the current JIRA setup.

            Show
            kutzi kutzi added a comment - The version fields in JIRA only have the Jenkins core versions. This is a known limitation of the current JIRA setup.

              People

              • Assignee:
                Unassigned
                Reporter:
                simabeis Marcel Beister
              • Votes:
                8 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: