Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13913

after upgrading Subversion Plugin to 1.40 some (not all) project are building again and again

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.465
      Subversion Plug-in 1.40
      windows 7

      Description

      I upgraded subversion plugin one or 2 weeks ago

      The first time one of our project sources have been updated in SVN, this project is build again and again with the following code change info:

      {Started on 25 mai 2012 13:50:49 Workspace doesn't contain https://xxx.yyy.com:443/svn/applications/2011/Telefonica/SelfCareApp/trunk/sources. Need a new build Done. Took 0,2 s Changes found}

      This happens with both modes :

      • Emulate clean checkout by first deleting unversioned/ignored files
      • always check up a fresh copy
        (I even deleted manually the workspace, in both configuration to be sure to avoid any memorizing side-effect of the extracted source code)

      It also happens on another single project yesterday after its source has been updated.
      All other projects are currently working correctly (ie only rebuilding when the svn source change).

      A weird thing is that it is the same user who updated the code in both projects

      This issue is similar to the JENKINS-13835 issue but in our case we have more than 12 living builds, only two seems impacted for the moment-

        Issue Links

          Activity

          Hide
          christophem christopheM added a comment -

          my issue was related to the presence of :443 after the svn host url so :

          • https:/my.svn.com:443/path failed on some jobs (bot all of them) and these jobs were building repeatedly
          • https:/my.svn.com/path worked correctly for these jobs
          Show
          christophem christopheM added a comment - my issue was related to the presence of :443 after the svn host url so : https:/my.svn.com:443/path failed on some jobs (bot all of them) and these jobs were building repeatedly https:/my.svn.com/path worked correctly for these jobs
          Hide
          alghe Alexandru Gheorghe added a comment - - edited

          Same for me christopheM, I'd like to add here my comment from JENKINS-10222, however, simple https url didn't help, neither @HEAD workaround.

          Show
          alghe Alexandru Gheorghe added a comment - - edited Same for me christopheM , I'd like to add here my comment from JENKINS-10222 , however, simple https url didn't help, neither @HEAD workaround.

            People

            • Assignee:
              Unassigned
              Reporter:
              christophem christopheM
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: