Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13967

Xunit don't recognize cppunit report with time execution

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      Ubuntu Desktop 12.04 64 bits with Jenkins 1.466 with tomcat7 (from ubuntu package)
      cppunit -1.12.1-4 (from ubuntu package)
    • Similar Issues:

      Description

      Hi,

      Since I have added the clocker plugin to my cppunit code(It is a cppunit plugin which permit to have the time execution, available into the samples of the cppunit archive), xunit don't reconize the format of the cppunit report.

      In fact, jenkins says that :
      [xUnit] [INFO] - Starting to record.
      [xUnit] [INFO] - Processing CppUnit-1.12.1 (default)
      [xUnit] [INFO] - [CppUnit-1.12.1 (default)] - 1 test report file(s) were found with the pattern 'report/cppunit-report.xml' relative to '/home/nicolas/jenkins/workspace/ProjectA' for the testing framework 'CppUnit-1.12.1 (default)'.

      [xUnit] [ERROR] - The result file '/home/nicolas/jenkins/workspace/ProjectA/report/cppunit-report.xml' for the metric 'CppUnit' is not valid. The result file has been skipped.
      [xUnit] [INFO] - Setting the build status to FAILURE
      [xUnit] [INFO] - Stopping recording.
      Build step 'Publish xUnit test result report' changed build result to FAILURE

        Attachments

        1. cppunit-report.xml
          2 kB
        2. input.xsl
          9 kB
        3. input.xsl
          9 kB

          Activity

          koni29 Nicolas JAN added a comment -

          XUnit parse the XML report without error. But the time execution of tests in xunit are always 0 ms.

          gbois Gregory Boissinot added a comment -

          Sure, this is the expected behavior at the moment because for this metric, a value of 0 is hardcoded.
          The XSL transformation file has to take care of this.
          Any contributions are welcome.
          Change to 'New Feature' for now.

          sbernaud sbernaud added a comment -

          I had the need to get execution times from cppunit today.
          Here is updated XSL.

          sbernaud sbernaud added a comment -

          XSL transformation to get execution times from cppunit/

          sbernaud sbernaud added a comment -

          the good one

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Gregory Boissinot
          Path:
          pom.xml
          http://jenkins-ci.org/commit/xunit-plugin/9fc487c1b44ef77d874122462106412d095a5806
          Log:
          Fix JENKINS-13967

          gbois Gregory Boissinot added a comment -

          Thank you for your input.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              koni29 Nicolas JAN
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: