Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Recently I upgraded from an older version of Hudson to the newest version and
      also the cobertura plugin. Since this upgrade hudson can not find my
      coverage-results anymore. I've tried to enter the full path to the xml-file but
      without any luck. I've also tried cobertura/coverage.xml and
      ./cobertura/coverage.xml without any luck. I'm using SVN and the folder is in my
      workspace-map and it worked in the past.

        Attachments

          Activity

          davidmc24 davidmc24 added a comment -

          As far as I can tell, the plugin's functionality to locate coverage results is functioning as intended. I've
          committed a patch to improve the help for this, which should be included in plugin version 0.8.7. I'm
          going to mark this issue as FIXED. If anyone has reason to think that there's more to this issue, feel free to
          re-open it.

          davidmc24 davidmc24 added a comment -

          Included in cobertura plugin version 0.8.7, which is now released.

          timboven timboven added a comment -

          I've just upgraded my covertura plugin to 0.8.7 and tried a basic test with it
          but without any luck. (Hudson is also up-to-date)

          In the log I get:
          No coverage results were found using the pattern '../cobertura/coverage.xml'
          relative to '/home/wwwHome/jobs/test/workspace/test'. Did you enter a pattern
          relative to the correct directory? Did you generate the XML report(s) for
          Cobertura?

          If I open a shell to the box and move to the folder mentioned above, I can open
          the file without any problem:
          [timboven@freebsd /home/wwwHome/jobs/test/workspace/test]$ vi
          ../cobertura/coverage.xml
          gives me the xml.

          The project in question is checked out from cvs but I've also checked out an
          extra module.

          davidmc24 davidmc24 added a comment -

          The plugin is currently working as-intended when it doesn't recognize Cobertura report XML files that are
          outside of the "module root" (for Subversion/CVS/ClearCase snapshots, this is a level beneath the
          workspace directory). If you are generating your Cobertura report XML files somewhere outside of the
          module root, you can't use ".." within the report pattern to navigate outside of the module root. Since this
          behavior is working as intended, no further changes will be implemented under this ticket.

          If you would like the ability to have your coverage XML files somewhere other than the module root,
          please vote for enhancement 3862, which proposes adding an additional configuration field to specify
          this.

          davidmc24 davidmc24 added a comment -

          No further work intended towards this ticket. If you want the ability to configure what directory your
          "Cobertura xml report pattern" is relative to, please vote for issue 3862.


            People

            • Assignee:
              davidmc24 davidmc24
              Reporter:
              timboven timboven
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: