Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14514

Repeatable jelly tag appears to be broken in 1.474+

    Details

    • Similar Issues:

      Description

      I used Jenkins 1.474 and installed the Publish Over SSH(1.7). I can configure the SSH server in the Configure System.
      But it can't work at the job configure.

      I clicked "Add post-build action" and selected "Send build artifacts over SSH" and than I clicked the button "Add Server" , and when I clicked the button "Add Transfer Set".there is no response. In the noraml we can see the label "Source files" and "Remove prefix" and others,what's wrong ? you can see the attend file"1.7.jpg"

      we can see the label "Source files" and "Remove prefix" and others using the Publish Over SSH(1.4). you can see the attend file "1.4.jpg"

        Attachments

        1. 1.4.jpg
          1.4.jpg
          93 kB
        2. 1.7.jpg
          1.7.jpg
          39 kB

          Issue Links

            Activity

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1825
            [FIXED JENKINS-14514] 96442cd broke "Add <Something>" buttons for many plugins. (Revision acf394f4f65b6bb77d3737dff2159f0d336129dc)
            JENKINS-14434 JENKINS-14514 Noting. (Revision 35af5960eadf193a7502807a9f901cc5b1186f4d)

            Result = SUCCESS
            Jesse Glick : acf394f4f65b6bb77d3737dff2159f0d336129dc
            Files :

            • core/src/main/resources/lib/form/repeatable/repeatable.js

            Jesse Glick : 35af5960eadf193a7502807a9f901cc5b1186f4d
            Files :

            • changelog.html
            bporter Brian Porter added a comment -

            Commenting here since 14381 resolved as duplicate of this issue. Issue with HTML Publisher remains - adding post build action of Publish HTML reports does not show data entry fields. I have updated to the current 1.476 war file and restarted server.

            jglick Jesse Glick added a comment -

            @Brian: not really sure what is in 1.476; http://jenkins-ci.org/changelog does not list it, and there is no tag for it! I think I specifically tested the HTML Publisher plugin against this change, but if you still see the bug when running against master (currently 1.477-SNAPSHOT) please reopen JENKINS-14381.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            changelog.html
            core/src/main/resources/lib/form/repeatable/repeatable.js
            war/src/main/webapp/scripts/behavior.js
            http://jenkins-ci.org/commit/jenkins/dbb100da58a084fb0a6ce129d3f2b7ad827e87ee
            Log:
            [FIXED JENKINS-14495] Hetero lists not working correctly after adding elements.
            Unlike JENKINS-14514 this is a true fix rather than a workaround (now removed), and is more general.
            cjo9900 discovered that behaviors were being redundantly registered (as of 1.474 the monolithic JS is broken up);
            this caused some behaviors to be run repeatedly on the same elements, breaking reasonable expectations of some behaviors.
            The ideal fix would be to change Behavior.register to be idempotent: for example, key it by selector, then maintain a set of distinct behavior functions for each.
            Unfortunately some adjuncts directly call Behavior.list.unshift, bypassing register(...), which would be tricky to intercept (would need to make a mock of Array).
            The known one cases are in core, but it is possible plugin adjuncts do this too, in which case it would be incompatible to (say) change the Array<Map<String,Behavior>> to a Map<String,Array<Behavior>>.
            Instead, permitting redundant registrations as before, and just silently skipping all but the first at runtime when applying behaviors.
            Beware that since adjuncts are loaded from multiple places, different JS function objects are registered each time, so a naive set of behavior functions does not work;
            have to identify functions by their toString in order to ensure that each is run only once.
            (Currently once per selector, conceivably >1x per element; could if necessary be refined to make sure a given behavior is only run once on a given element during one call to applySubtree even if the element matches multiple selectors.)


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                msfly MS FLY
              • Votes:
                5 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: