Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14641

testIsSymlink is not ignored on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      testIsSymlink in UtilTest.java should be ignored because of the following:

      Assume.assumeTrue(!Functions.isWindows());

      but the test is not ignored.

        Attachments

          Activity

          erik_molekamp Erik Molekamp added a comment -

          The problem is caused by "extends TestCase", i.e. using JUnit 3.8 functionality.
          Assume was added in JUnit 4 so the JUnit38ClassRunner does not know that AssumptionViolatedException does not imply a fail but should result in an ignored test instead.
          (See also: http://issues.gradle.org/browse/GRADLE-1879 )

          I propose to upgrade UtilTest to JUnit 4.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christoph Kutzinski
          Path:
          core/src/test/java/hudson/UtilTest.java
          http://jenkins-ci.org/commit/jenkins/d5017813ecd411a30de12008778955ec3bf051d2
          Log:
          Converting to JUnit 4 thus fixing JENKINS-14641 and also fixing test(Html)Escape which didn't ran previously because of wrong case

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #1866
          Converting to JUnit 4 thus fixing JENKINS-14641 and also fixing test(Html)Escape which didn't ran previously because of wrong case (Revision d5017813ecd411a30de12008778955ec3bf051d2)

          Result = SUCCESS
          Christoph Kutzinski : d5017813ecd411a30de12008778955ec3bf051d2
          Files :

          • core/src/test/java/hudson/UtilTest.java

            People

            • Assignee:
              erik_molekamp Erik Molekamp
              Reporter:
              slide_o_mix Alex Earl
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: