Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14856

Slave Registered Remote Controls not identified in Jenkins Selenium Grid

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: selenium-plugin
    • Labels:
      None
    • Environment:
      Linux RHEL server
      Linux Ubuntu slave agent remote client
    • Similar Issues:

      Description

      I was attempting to rename the newest selenium-server-standalone-*.jar to replace the older one (as per some of the users posts).
      When I restarted the Jenkins server, the Selenium Grid page shows that the jenkins.nodeName is null for all of the connected remote contols clients (as shown below)

      {seleniumProtocol=Selenium, browserName=*firefox, maxInstances=5, jenkins.nodeName=}

      I put everything back the way it was, but this problem still exists, and the process for the hudson.remoting.Launcher of the selenium-server-standalone-*.jar is not running on the agents.

      Everything says that it should automatically configure and start when the Jenkins server is restarted.

        Attachments

          Activity

          darkrift Richard Lavoie added a comment -

          Does that happen when using the latest 2.2 version ?

          rejesi rejesi added a comment -

          Closing this issue as it was probably user error.

          rejesi rejesi added a comment -

          I believe that somehow it was user error. It resolved and started showing properly after a week or so. I have since stopped using this plugin.

          I will close this issue.


            People

            • Assignee:
              darkrift Richard Lavoie
              Reporter:
              rejesi rejesi
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: