Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15169

Warning Plugin - Graph Configuration Error

    Details

    • Similar Issues:

      Description

      Attempting to configure the trend graph results in http 404 page not found error.
      1) Go to a job with trend grpahs displayed.
      2) Click configure link (links to <Jenkins Server>/<Job>/warnings6/configure/?)
      3) Click Save (links to <Jenkins Server>/<Job>/warnings6/configure/save)

      Versions installed
      Jenkins 1.481
      Warnings 4.17
      Static Code Analysis Plugin 1.47
      Analysis Collector Plugin 1.33
      Violations 0.7.11

      Issues accesses Jenkins through the localhost path.

        Attachments

          Activity

          Hide
          drulli Ulli Hafner added a comment -

          Maybe the redirect after the save is broken in your setup. Does the new value get stored? Did you set/change the Jenkins URL in the system configuration?

          Can you please check if the created URLs are different than the URLs when trying the same on our public Jenkins instance:
          https://ci.jenkins-ci.org/view/Jenkins%20core/job/jenkins_main_trunk/

          Show
          drulli Ulli Hafner added a comment - Maybe the redirect after the save is broken in your setup. Does the new value get stored? Did you set/change the Jenkins URL in the system configuration? Can you please check if the created URLs are different than the URLs when trying the same on our public Jenkins instance: https://ci.jenkins-ci.org/view/Jenkins%20core/job/jenkins_main_trunk/
          Hide
          engler Chris Engler added a comment - - edited

          I checked the URL provided, I could change the graphs.

          I went back to my server. Starting in Local Host, the graph information does get saved, but it does take me to the 404 page still.
          Going to my sever from the Jenkins URL, configuring the graphs displays and there is no 404 error after save.

          Is it possible to have the same behavior when going throught the localhost address?

          Show
          engler Chris Engler added a comment - - edited I checked the URL provided, I could change the graphs. I went back to my server. Starting in Local Host, the graph information does get saved, but it does take me to the 404 page still. Going to my sever from the Jenkins URL, configuring the graphs displays and there is no 404 error after save. Is it possible to have the same behavior when going throught the localhost address?
          Hide
          drulli Ulli Hafner added a comment -

          It would help see see the difference between the working and broken URL. Can you please post?

          Show
          drulli Ulli Hafner added a comment - It would help see see the difference between the working and broken URL. Can you please post?
          Hide
          engler Chris Engler added a comment -

          Interesting, I was setting up the server to get you to look at the URL. Local host now keeps the pictures, the save button launches to the named Jenkins URL and not in local host. Using LDAP, I'm still logged into Jenkins. Outside of the login, the graphs work, and the save button still lauches to the named Jenkins URL.

          Show
          engler Chris Engler added a comment - Interesting, I was setting up the server to get you to look at the URL. Local host now keeps the pictures, the save button launches to the named Jenkins URL and not in local host. Using LDAP, I'm still logged into Jenkins. Outside of the login, the graphs work, and the save button still lauches to the named Jenkins URL.

            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              engler Chris Engler
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: