Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15680

I get this error when using maven release plugin: cvs commit: cannot commit with sticky date for file `pom.xml'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: cvs-plugin, release-plugin
    • Labels:
      None
    • Environment:
      Windows Jenkins version 1.486
      Linux Jenkins 1.480.2, cvs-plugin 2.7
    • Similar Issues:

      Description

      I get this error when running the Perform Maven Release task on one of my projects whose source code is checked out from CVS.

      cvs commit: cannot commit with sticky date for file `pom.xml'

      The problem is that maven is trying to commit the modified pom.xml to CVS but that file cannot be committed since it was checked out with a sticky date.

      Any ideas?

        Attachments

          Issue Links

            Activity

            mc1arke Michael Clarke added a comment -

            Sorry, I'm not sure what the issue is here. You need to perform a checkout without setting the -d option on the checkout command. This issue isn't a restriction that's being forced by Jenkins, but a restriction on CVS.

            saschavogt Sascha Vogt added a comment - - edited

            We're facing the same issue.
            It seems to be related to the Jenkins CVS plugin (after updating from 1.2 to 2.7 which was a change from the commandline cvs client to the Netbeans Java API).

            Comparing the output, it seems that now the plugin also uses "-r HEAD" for checkout / update:
            old

            cvs -q -z3 update -PdC -D "Friday, December 7, 2012 1:30:28 PM UTC"

            vs. new

            cvs update -d -P -r HEAD -D 14 Jan 2013 10:33:16 +0100 workspace

            Using the flag "Legacy Mode" changes the command to

            cvs update -P -N -D 14 Jan 2013 12:22:23 +0100 <Module-path>

            which seems to be a workaround.

            I had a look at the cvs documentation, and there it is stated that -D and -r are exclusive or (so I think the new command with specifiying both isn't quite correct)

            saschavogt Sascha Vogt added a comment -

            Actually I think this was related to https://issues.jenkins-ci.org/browse/JENKINS-16412
            Maybe this one can be closed as well?

            mc1arke Michael Clarke added a comment -

            Closing as per last comment


              People

              • Assignee:
                mc1arke Michael Clarke
                Reporter:
                rmarpozo Ruben Martin Pozo
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: