Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15819

The name of the archived directory/file is garbled.(保存された成果物のディレクトリ/ファイル名が文字化けする)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
    • Environment:
      master : Linux (CentOS 6.3)
      slave : Windows7, WindwsXP
    • Similar Issues:

      Description

      Steps to reproduce the symptom (現象と再現手順)

      1. Configure job settings and run the job.
        (ジョブの設定と実行)
        Enable "Archive the artifacts" option in the "Post-build Actions" section at a job settings page, and run the job.
        (ジョブの設定で、"ビルド後の処理"の"成果物を保存"を有効にし、ジョブを実行する)
      2. The name of the archived directory/file is garbled.
        (保存された成果物のディレクトリ/ファイル名が文字化けする)
        If the name of directory/file which is located at the slave node contains some Japanese words, the archived file/directory name is garbled.
        (保存された成果物のディレクトリ名、もしくはファイル名が文字化けしてしまう。この現象は、スレーブ上にある、日本語のファイルを保存しようとしたときに発生する。)

      Below are our a bug example.

      • File name in the workspace environment
        log/テストログ.log
      • File name of the archived artifacts
        log/ᅥᄍ￈■ᄚ.log

        Attachments

          Activity

          evernat evernat added a comment -

          Is it reproduced with a recent Jenkins version?

          oleg_nenashev Oleg Nenashev added a comment -

          No response from the requester.

          lly Lars Lykke added a comment - - edited

          I'm able to reproduce this issue (or something apparently similar) on Jenkins v. 1.581.
          My steps to reproduce is to
          1) Check out files from our SCM (StarTeam plugin)
          2) Verify files containing special characters are correct in the workspace (which they are)
          3) After the files have been archived using the standard Archive Artifacts Post build step, the filenames containing special chars have been garbled.

          So files are retrieved correctly from SCM but get their filename garbled upon archiving.

          In my particular case the filenames contain the characters 'æ', 'ø' and 'å'. These are the chars being garbled by the archiving step.
          I've been searching for a way of testing whether or not I could influence the setting via some sort of startup parameter to Jenkins but with no luck in finding such. Is this just because I've failed to supply the right locale setting or encoding?
          Master is a Windows 7 pc. Slave is also Windows 7.

          I tried changing the checkout and archiving task to run on the master instead of the slave. The filenames were then no longer garbled!?

          danielbeck Daniel Beck added a comment -

          Lars: Please file a new issue against the 'core' component. Include all of the information you mentioned here.


            People

            • Assignee:
              Unassigned
              Reporter:
              den00039 Ryuichi Azuma
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: