Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16256

ArrayIndexOutOfBoundsException when accessing lazily loaded run map

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.492, findbugs plug-in 4.45, JDK 1.7.0, Solaris.
    • Similar Issues:

      Description

      Caused by: java.lang.ArrayIndexOutOfBoundsException: Assertion error: failing to load #10 DESC: lo=471,hi=0,size=838,size2=838
      at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:418)
      at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:207)
      at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
      at hudson.model.Run.onLoad(Run.java:305)
      at hudson.model.RunMap.retrieve(RunMap.java:221)
      at hudson.model.RunMap.retrieve(RunMap.java:59)

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Can you please show more details? I'm wondering why this logging statement should fail the build? Can you show the rest of the console log that shows the build result evaluation of findbugs?

            guyrixon Guy Rixon added a comment -

            Full log is attached.

            I tried the Jenkins job without the findbugs goal and it succeeded.

            guyrixon Guy Rixon added a comment -

            I have just upgraded Jenkins to 1.467 and the job now succeeds with findbugs included. The underlying problem of findbugs trying to copy java.io.File is still there in the log (and the other problem of Cobertura not knowing Java 7), but the job finishes correctly.

            drulli Ulli Hafner added a comment -

            Ok, good to see that this was a problem related to an old Jenkins version. From the log I see that the build failure was caused by an Exception...

            guyrixon Guy Rixon added a comment -

            The failure has now come back; symptoms are as per the previous log. The Maven project underlying the job has had some code commits but the Jenkins configuration and job configuration have not changed.

            guyrixon Guy Rixon added a comment -

            OK, based on 3 cycles findbugs/no-findbugs, then two successive runs with no findbugs, it "always" fails with findbugs and "always" succeeds without. Not sure why it worked once with findbugs earlier today.

            drulli Ulli Hafner added a comment - - edited

            Ok, I'm reopening the issue. Which Jenkins version are you using now? You said you upgraded to 1.467 but in the environment version 1.492 is reported...

            The exception is from Jenkins core, indicating that not all build results could be read.

            drulli Ulli Hafner added a comment -

            Ok, I think this problem has been reported already. It is not related to findbugs, it is a bug in the new feature of lazy loading of the build results.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                guyrixon Guy Rixon
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: