Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16448

WORKSPACE env variable is incorrect for matrix project

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: matrix-project-plugin
    • Labels:
      None
    • Environment:
      Firefox 18.0
      Ubuntu 10.04 LTS
      Jenkins core 1.499
      Dynamic Axis plugin 1.0.1
    • Similar Issues:

      Description

      The WORKSPACE environment variable has the value of a since long deleted project.

      When the job starts, the workspace is correct according to the console log, but the WORKSPACE environment variable is not.

      FailedConsole Output

      09:20:03 Started by upstream project "magjac-main-sw071" build number 4
      09:20:03 originally caused by:
      09:20:03 Started by user magjac
      09:20:03 [EnvInject] - Loading node environment variables.
      09:20:03 [EnvInject] - Preparing an environment for the build.
      09:20:03 [EnvInject] - Keeping Jenkins system variables.
      09:20:03 [EnvInject] - Keeping Jenkins build variables.
      09:20:03 [EnvInject] - Adding build parameters as variables.
      09:20:03 [EnvInject] - Injecting contributions.
      09:20:03 Building in workspace /var/lib/jenkins/jobs/magjac-main-sw071/workspace/SUBSYSTEM/nosa
      09:20:03 [nosa] $ /bin/sh -xe /tmp/SUBSYSTEM=nosa1981765562294024819.sh
      09:20:03 + echo TEST_IMAGE_URL=http://selby.netinsight.se/builds/main/UNSET/release/
      09:20:03 + echo TEST_NODE=sw071
      09:20:03 + echo TEST_NODE_NAME=sw071
      09:20:03 [environment-script] Adding variable 'TEST_IMAGE_URL' with value 'http://selby.netinsight.se/builds/main/UNSET/release/'
      09:20:03 [environment-script] Adding variable 'TEST_NODE' with value 'sw071'
      09:20:03 [environment-script] Adding variable 'TEST_NODE_NAME' with value 'sw071'
      09:20:03 [locks-and-latches] Checking to see if we really have the locks
      09:20:03 [locks-and-latches] Have all the locks, build can start
      09:20:03 [nosa] $ /bin/sh -xe /tmp/hudson1228848805168783945.sh
      09:20:03 + /usr/local/bin/publish-smoketest START main nosa_sw071
      09:20:04 Ok
      09:20:04 [nosa] $ /bin/bash /tmp/hudson1457749116163454260.sh
      09:20:04 + rm -rf sw infrastructure logs
      09:20:04 + mkdir logs
      09:20:04 + git clone ssh://gitosis@git.netinsight.se/sw/main/tools/systest.git sw/main/tools/systest
      09:20:04 Initialized empty Git repository in /var/lib/jenkins/jobs/magjac-main-sw071/workspace/SUBSYSTEM/nosa/sw/main/tools/systest/.git/
      09:20:04 + git clone ssh://gitosis@git.netinsight.se/sw/main/nosa.git sw/main/nosa
      09:20:04 Initialized empty Git repository in /var/lib/jenkins/jobs/magjac-main-sw071/workspace/SUBSYSTEM/nosa/sw/main/nosa/.git/
      09:20:07 + git clone ssh://gitosis@git.netinsight.se/infrastructure/ci-tools.git infrastructure/ci-tools
      09:20:07 Initialized empty Git repository in /var/lib/jenkins/jobs/magjac-main-sw071/workspace/SUBSYSTEM/nosa/infrastructure/ci-tools/.git/
      09:20:07 [nosa] $ /bin/bash /tmp/hudson7556196773920985672.sh
      09:20:07 + export PYTHONPATH=/var/lib/jenkins/jobs/main-multiconf/workspace/sw/main/tools/systest/lib/pconf
      09:20:07 + PYTHONPATH=/var/lib/jenkins/jobs/main-multiconf/workspace/sw/main/tools/systest/lib/pconf
      09:20:07 + '[' false == true ']'
      09:20:07 [nosa] $ /bin/bash /tmp/hudson4803969337691787980.sh
      09:20:07 + env
      09:20:07 LC_PAPER=sv_SE.UTF-8
      09:20:07 BUILD_URL=http://smoketest.netinsight.se/job/magjac-main-sw071/./SUBSYSTEM=nosa/4/
      09:20:07 HUDSON_SERVER_COOKIE=838b4f674e5926c0
      09:20:07 SHELL=/bin/bash
      09:20:07 TERM=rxvt
      09:20:07 BUILD_TAG=jenkins-magjac-main-sw071-SUBSYSTEM=nosa-4
      09:20:07 SUBSYSTEM=nosa
      09:20:07 WORKSPACE=/var/lib/jenkins/jobs/main-multiconf/workspace
      09:20:07 CONFIG_FILE=sw071.rc
      09:20:07 JOB_URL=http://smoketest.netinsight.se/job/magjac-main-sw071/./SUBSYSTEM=nosa/
      09:20:07 USER=jenkins
      09:20:07 LD_LIBRARY_PATH=/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server:/usr/lib/jvm/java-6-openjdk/jre/lib/amd64:/usr/lib/jvm/java-6-openjdk/jre/../lib/amd64
      09:20:07 TEST_NODE=sw071
      09:20:07 BUILD_CAUSE_UPSTREAMTRIGGER=true
      09:20:07 DO_INSTALL=false
      09:20:07 JENKINS_HOME=/var/lib/jenkins
      09:20:07 PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
      09:20:07 MAIL=/var/mail/jenkins
      09:20:07 LC_COLLATE=sv_SE.UTF-8
      09:20:07 PWD=/var/lib/jenkins/jobs/magjac-main-sw071/workspace/SUBSYSTEM/nosa
      09:20:07 HUDSON_URL=http://smoketest.netinsight.se/
      09:20:07 LANG=C
      09:20:07 JOB_NAME=magjac-main-sw071/SUBSYSTEM=nosa
      09:20:07 DO_TEST=true
      09:20:07 JENKINS_URL=http://smoketest.netinsight.se/
      09:20:07 BUILD_CAUSE=UPSTREAMTRIGGER
      09:20:07 BUILD_ID=2013-01-23_09-20-03
      09:20:07 NETI_BUILDID=UNSET
      09:20:07 HOME=/var/lib/jenkins
      09:20:07 SHLVL=2
      09:20:07 JENKINS_SERVER_COOKIE=838b4f674e5926c0
      09:20:07 EXECUTOR_NUMBER=1
      09:20:07 NODE_LABELS=master
      09:20:07 LOGNAME=jenkins
      09:20:07 TEST_NODE_NAME=sw071
      09:20:07 TEST_IMAGE_URL=http://selby.netinsight.se/builds/main/UNSET/release/
      09:20:07 HUDSON_HOME=/var/lib/jenkins
      09:20:07 LC_CTYPE=sv_SE.UTF-8
      09:20:07 NODE_NAME=master
      09:20:07 SUBSYSTEMS=nosa
      09:20:07 BUILD_NUMBER=4
      09:20:07 HUDSON_COOKIE=2a9b3d26-0dbb-4113-aa7a-4efa3cfd5020
      09:20:07 DISPLAY=worabu.netinsight.se:0.0
      09:20:07 LC_TIME=en_DK.UTF-8
      09:20:07 TRACK=main
      09:20:07 _=/usr/bin/env
      09:20:07 + export PYTHONPATH=/var/lib/jenkins/jobs/main-multiconf/workspace/sw/main/tools/systest/lib:sw/main/nosa/systest
      09:20:07 + PYTHONPATH=/var/lib/jenkins/jobs/main-multiconf/workspace/sw/main/tools/systest/lib:sw/main/nosa/systest
      09:20:07 + cp -p /var/lib/jenkins/jobs/main-multiconf/workspace/infrastructure/ci-tools/pconf_rc/sw071.rc /var/lib/jenkins/jobs/main-multiconf/workspace/pconf.rc
      09:20:07 cp: cannot stat `/var/lib/jenkins/jobs/main-multiconf/workspace/infrastructure/ci-tools/pconf_rc/sw071.rc': No such file or directory

      ...

        Attachments

          Activity

          magjac Magnus Jacobsson added a comment -
          gbois Gregory Boissinot added a comment -

          Could you isolate the problem in a clean environment?

          magjac Magnus Jacobsson added a comment -

          No, I only have access to one Jenkins server (and it's not clean).

          magjac Magnus Jacobsson added a comment -

          This is indeed a duplicate of https://issues.jenkins-ci.org/browse/JENKINS-16233. I have now seen it also for a non-matrix job.


            People

            • Assignee:
              Unassigned
              Reporter:
              magjac Magnus Jacobsson
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: