Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16494

Jenkins Grails Plugin 1.6.3 does not install a runtime correctly

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: grails-plugin
    • Labels:
    • Environment:
      Jenkins Grails Plugin 1.6.3
      Attempting to install onto a Jenkins instance running on Red Hat 4.1.2-51
    • Similar Issues:

      Description

      I'm attempting to install grails from the Jenkins Grails Plugin (1.6.3). The plugin seemed to install just fine. When I try to install a version of grails, it isn't working as I would expect.
      When I'm on the "Manage Jenkins"->"Configure System" screen, the Grails Plugin doesn't have a drop-down of grails versions to choose from when I attempt to install from mirrors. Instead I see a text box that I can type in (see my attached screen shot 'grails_plugin_no_installer.png', where the red arrow is pointing).
      As you can see from the screen shot, I also tried to install it directly from a binary archive.
      In both cases, after filling out the info as you see it and pressing the 'save' button. Then when I run my job that uses the grail build step (attached screen shot 'build_with_grails_war.png'), I get the error message in attached screen shot 'build_failed.png'.

      My first guess was that the server didn't have access to the internet - which might explain why it couldn't find any mirrors to display - but telnet and curl are able to hit internet sights just fine.

      I have another instance of Jenkins (also Redhat) where an older version of the Grails Plugin works just fine (1.5). The only notable difference between those instances of Jenkins is that the one that does not work has CloudBees installed, and the one where it works does not have CloudBees installed.

      I'm hoping that I'm missing something simple here. Please help me identify the issue and get a version of grails installed on this server. What other info do you need to help debug this?

      Thank you.

        Attachments

          Activity

          jglick Jesse Glick added a comment -

          Testing against OSS Jenkins I get a dropdown for Version from 2.2.0 downward, as http://updates.jenkins-ci.org/updates/com.g2one.hudson.grails.GrailsInstaller.json supplies; when used, http://dist.springframework.org.s3.amazonaws.com/release/GRAILS/grails-2.2.0.zip is unpacked and run as expected. Same when running against Jenkins Enterprise 1.466.12.1. You should have seen in your log file, sometime after installing the plugin:

          …date… hudson.model.DownloadService$Downloadable doPostBack
          INFO: Obtained the updated data file for com.g2one.hudson.grails.GrailsInstaller
          

          As for the generic installation from URL, delete the Label (you misinterpret it; see inline help); and you must set grails-2.1.1 in the Subdirectory of extracted archive field. With those changes, the generic installation works for me too.

          While inspecting the code I found some erroneous logic which I have submitted a fix for in https://github.com/jenkinsci/grails-plugin/pull/4 but I do not see any obvious reason why the bad code would have led to the symptoms you describe.


            People

            • Assignee:
              jeffg2one jeffg2one
              Reporter:
              ddowma Dan Dowma
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: