Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16497

Builds with surefire on Windows OS prevent deletion of files with output from tests.

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Windows
    • Similar Issues:

      Description

      Builds with surefire on Windows OS prevent deletion of files with output from tests. These files are created when maven.test.redirectTestOutputToFile is activated.

      There is a known problem with memory mapped io on windows os:
      "[...] Windows does not allow a mapped file to be deleted [...]"
      http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4715154

      hudson.tasks.junit.SuiteResult uses memory mapped io to read the redirected test output.

      I have attached a patch (noMemoryMappedIoForWindows-V2.patch), that reactivates an older implementation without memory mapped io on windows. I think this patch is only a temporary solution, because it reintroduces a memory problem. This problem was solved with memory mapped io.

        Attachments

          Issue Links

            Activity

            mo2000 Marc-Olaf Jaschke added a comment -

            Please ignore/delete the two patch files with the name noMemoryMappedIoForWindows.patch, they are flawed.

            marnix_klooster Marnix Klooster added a comment -

            We're running into this issue as well, many times. Is there any progress on this issue? Has anyone looked at the V2 patch?

            Thanks!

            marnix_klooster Marnix Klooster added a comment -

            Also, does anyone know of a workaround?


              People

              • Assignee:
                Unassigned
                Reporter:
                mo2000 Marc-Olaf Jaschke
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: