Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16666

Jabber plugins stops working after upgrading to Jenkins 1.499

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: jabber-plugin
    • Labels:
    • Environment:
      OS: FreeBSD 7.2
      Jenkins: 1.499
    • Similar Issues:

      Description

      After upgrading to Jenkins 1.499, and upgrading Jabber plugin from version 1.22 to 1.25, and instant message plugin with 1.25, chat notification stops working.

        Attachments

          Activity

          lpurba Laurentius Purba added a comment -

          Hi kutzi,

          I tried downloading and re-install jenkins, and it still gives me the same error.

          FATAL: hudson/model/ResultTrend
          java.lang.NoClassDefFoundError: hudson/model/ResultTrend
          at hudson.plugins.im.build_notify.SummaryOnlyBuildToChatNotifier.buildCompletionMessage(SummaryOnlyBuildToChatNotifier.java:39)
          at hudson.plugins.im.build_notify.DefaultBuildToChatNotifier.buildCompletionMessage(DefaultBuildToChatNotifier.java:50)
          at hudson.plugins.im.IMPublisher.notifyChatsOnBuildEnd(IMPublisher.java:577)
          at hudson.plugins.im.IMPublisher.notifyOnBuildEnd(IMPublisher.java:304)
          at hudson.plugins.im.IMPublisher.perform(IMPublisher.java:291)
          at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
          at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:630)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:608)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:584)
          at hudson.model.Build$RunnerImpl.post2(Build.java:159)
          at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:553)
          at hudson.model.Run.run(Run.java:1391)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:145)
          Caused by: java.lang.ClassNotFoundException: hudson.model.ResultTrend
          at org.aspectj.weaver.bcel.ExtensibleURLClassLoader.findClass(ExtensibleURLClassLoader.java:54)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
          at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
          ... 15 more

          While below is from catalina.log

          INFO: Trying to reconnect
          Feb 8, 2013 5:55:36 PM hudson.plugins.jabber.im.transport.JabberIMConnection createConnection
          INFO: Trying to connect to XMPP on chat.MYDOMAIN.com:5222/chat.MYDOMAIN.com with SASL
          Feb 8, 2013 5:55:36 PM hudson.plugins.jabber.im.transport.JabberIMConnection setupSubscriptionMode
          INFO: Accepting all subscription requests
          Feb 8, 2013 5:55:36 PM hudson.plugins.jabber.im.transport.JabberIMConnection connect
          INFO: Connected to XMPP on chat.MYDOMAIN.com:5222/chat.MYDOMAIN.com using TLS

          Any idea?

          Thanks!
          -Laurent

          kutzi kutzi added a comment -

          Sorry, no real clue.
          Can you look into your Jenkins war file and confirm that it's the current one and that this class is there?
          I've got the suspicion that you have somewhere an older war lying around which is actually used to start your Jenkins.
          BTW: does the version info of the bottom of the Jenkins page really say "1.499"?

          lpurba Laurentius Purba added a comment -

          It was confirmed that the war file is correct with version 1.4999.

          Also, there was no older war lying around that started my Jenkins.

          Thanks!
          -laurent

          kutzi kutzi added a comment -

          > Can you look into your Jenkins war file and confirm that it's the current one and that this class is there?

          kutzi kutzi added a comment -

          No response from reporter -> closing as cannot reproduce


            People

            • Assignee:
              kutzi kutzi
              Reporter:
              lpurba Laurentius Purba
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: