Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17059

Subversion fails when checking out from repository

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      Jenkins master 1.504 running on Windows Server 2008 64Bit. Was also a problem with 1.50[1,2,3]
    • Similar Issues:

      Description

      When a slave attempts to check out or update from the repository we get the error below.

      Have tried with OSX Slave and Ubuntu Slave, with basic HTTP authentication and on a completely different server over svn:// and no authentication.

      A manual checkout via the command-line works okay.

      Slave is running the same user as the manual checkout was run as.

      I have tired all the different versions of SVN in the configuration dropdown box.

      The repository url validates okay, and displays an error as expected if I get it wrong.

      Jenkins will report a problem if I put the wrong credentials when validating the URL, and accept them okay when I get them correct.

      The stacktrace in the console log is:

      Started by user Stuart Whelan
      Building remotely on Ubuntu in workspace /home/swhelan/jenkins/workspace/foo
      hudson.util.IOException2: remote file operation failed: /home/swhelan/jenkins/workspace/foo at hudson.remoting.Channel@211f1041:Ubuntu
      at hudson.FilePath.act(FilePath.java:861)
      at hudson.FilePath.act(FilePath.java:838)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:843)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:781)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1342)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:683)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:588)
      at hudson.model.Run.execute(Run.java:1567)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:237)
      Caused by: java.io.IOException: Remote call on Ubuntu failed
      at hudson.remoting.Channel.call(Channel.java:681)
      at hudson.FilePath.act(FilePath.java:854)
      ... 11 more
      Caused by: java.lang.NoSuchMethodError: org.tmatesoft.svn.core.wc.SVNBasicClient.getOperationsFactory()Lorg/tmatesoft/svn/core/wc2/SvnOperationFactory;
      at hudson.scm.SvnClientManager.wrapUp(SvnClientManager.java:46)
      at hudson.scm.SvnClientManager.getWCClient(SvnClientManager.java:38)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.parseSvnInfo(UpdateUpdater.java:114)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.isUpdatable(UpdateUpdater.java:87)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:120)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:153)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:903)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:884)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:867)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2348)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      Finished: FAILURE

        Attachments

          Activity

          kutzi kutzi added a comment -

          Sounds like there's somewhere an older, incompatible version of SVNKit in the classpath which is being used here.

          kutzi kutzi added a comment -

          Can you check which subversion-plugin you have installed and which svnkit version is in the plugins folder?

          stuartwhelan Stuart Whelan added a comment -

          I have 1.45 of subversion-plugin installed (also tried with 1.44)

          I cant see any svnkit in the plugins folder, have I missed a dependency?

          stuartwhelan Stuart Whelan added a comment -

          Found svnkit-1.7.6-jenkins-1.jar and svnkit-1.3.6.1-jenkins-2.jar in C:\Program Files (x86)\Jenkins\plugins\subversion\WEB-INF\lib

          kutzi kutzi added a comment -

          1.3.6 is too old. Remove it and it should AFAIK work fine.
          Must be some leftover of an incomplete plugin update.

          stuartwhelan Stuart Whelan added a comment -

          Problem was with an old svnkit-1.3.6.1-jenkins-2.jar in C:\Program Files (x86)\Jenkins\plugins\subversion\WEB-INF\lib

          Many thanks to kutzi for the help!


            People

            • Assignee:
              stuartwhelan Stuart Whelan
              Reporter:
              stuartwhelan Stuart Whelan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: