Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17154

CppCheck plugin cannot process result xml from slave node

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: cppcheck-plugin
    • Environment:
      Debian master/slave nodes.
      Jenkins ver. 1.505
      Jenkins Cppcheck Plug-in 1.13
    • Similar Issues:

      Description

      Result file on dev_slave node:

      [Cppcheck] Starting the cppcheck analysis.
      [Cppcheck] Processing 1 files with the pattern 'cppcheck-result.xml'.
      [Cppcheck] Error on cppcheck analysis: hudson.util.IOException2: remote file operation failed: /var/lib/jenkins/workspace/cpp_test at hudson.remoting.Channel@4abe67:dev_slave
      Build step 'Publish Cppcheck results' changed build result to FAILURE
      Build step 'Publish Cppcheck results' marked build as failure
      Notifying upstream projects of job completion
      Finished: FAILURE

      Result file on master:

      [Cppcheck] Starting the cppcheck analysis.
      [Cppcheck] Processing 1 files with the pattern 'result.xml'.
      [Cppcheck] Not changing build status, since no threshold has been exceeded
      [Cppcheck] Ending the cppcheck analysis.
      Notifying upstream projects of job completion
      Finished: SUCCESS

        Attachments

          Activity

          kovacsbalu Balint Kovacs added a comment -

          Workaround:

          1. On slave (creating result)
            • Run cppcheck script to create cppcheck-result.xml
            • Setup "Archive the artifacts" postbuild action to archive cppcheck-result.xml
          2. On master (publishing result)
            • Add a build step to copy artifacts from another project
            • Publish cpp checker result
          kovacsbalu Balint Kovacs added a comment -

          Now it is working with Jenkins ver. 1.514.

          kovacsbalu Balint Kovacs added a comment -

          Now it is working with Jenkins ver. 1.514.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              kovacsbalu Balint Kovacs
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: