Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17383

CVS plugin detect changes in 'rlog' but not in 'update'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      CVS plugin 2.8
    • Similar Issues:

      Description

      So this is what I'm doing:

      I commit a file from GMT+1 timezone (CET), the CVS server and jenkins are running on GMT-7 timezone (PDT).

      After the commit, the Jenkins server detects my change, and it displays the commit log in the "changes" page, but the "cvs update" does not update to the latest revision.

      This is when using the "Use Update" version, if I uncheck this option, the plugin performs a checkout and it works correctly, it retrieves the latest revision.

        Attachments

          Activity

          gpolet G P added a comment -

          OK so I confirm what Isaac mentions: the "Force clean copy for locally modified files" is the cause of all issues. Unchecking that option makes the CVS plugin work properly. I just switched back to v2.10 and with that version it works properly. So we should probably close this issue and reopen issue JENKINS-15848 which does not work correctly for now.

          Michael, if you need more info or you want me to perform other tests, let me know.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Michael Clarke
          Path:
          pom.xml
          http://jenkins-ci.org/commit/cvs-plugin/b3d0f6c51adddaa15032fe52c411415418098a29
          Log:
          [FIXED JENKINS-17383] Update to latest cvsclient

          newbie Sowrabha Chandrashekar added a comment - - edited

          CVS update command is not working with CVS plugin 2.8 and the below library.

          Below is the API, that I am calling for UpdateCommand :org.netbeans.lib.cvsclient.command.update.UpdateCommand

          <dependency>
          <groupId>org.jenkins-ci.lib</groupId>
          <artifactId>cvsclient</artifactId>
          <version>71-jenkins-11</version>
          </dependency>

          mc1arke Michael Clarke added a comment -

          Re-closing issue. Latest comment was unrelated, duplicated in another issue, and does not provide enough information to allow the issue to be replicated.


            People

            • Assignee:
              mc1arke Michael Clarke
              Reporter:
              icruz Isaac Cruz
            • Votes:
              9 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: