Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17679

Git plugins crashes with exception for jobs using git merging features

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Jenkins running on a debian master and multiple ubuntu linux slaves in different versions and with different JVM versions. Slaves are connected through ssh.
    • Similar Issues:

      Description

      Several of out build jobs using git are broken since some of the last version of the git plugin. They are crashing already in the main job triggering the individual builds with the following exception:

      Commencing build of Revision 5dc28f3d5e0787318df51a9cc58fdf712273ec7b (origin/bug-1175)
      hudson.util.IOException2: remote file operation failed: /home/jenkins/workspace/rsb-cpp-trunk-merge-simulator at hudson.remoting.Channel@44a89714:ubuntu_quantal_64bit
      at hudson.FilePath.act(FilePath.java:900)
      at hudson.FilePath.act(FilePath.java:877)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1121)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1367)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:674)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:579)
      at hudson.model.Run.execute(Run.java:1575)
      at hudson.matrix.MatrixBuild.run(MatrixBuild.java:304)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:237)
      Caused by: java.io.IOException: Unable to serialize hudson.FilePath$FileCallableWrapper@18379284
      at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
      at hudson.remoting.Channel.call(Channel.java:671)
      at hudson.FilePath.act(FilePath.java:893)
      ... 10 more
      Caused by: java.io.NotSerializableException: hudson.matrix.MatrixBuild
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1164)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:330)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:164)
      ... 13 more
      Finished: FAILURE

      All of the crashing jobs are matrix jobs using git and merging from a separate branch. Other jobs with git without merging are not affected by this.

      We are currently using version 1.3.0 of the git plugin and this version is affected by this bug.

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            Refer to JENKINS-16941 for an earlier report which matches this report. That earlier report also includes a link to a pull request which proposes to repair the problem. You could attempt to use that pull request yourself to confirm it resolves the issue for you.

            languitar Johannes Wienke added a comment -

            Yes, applying this pull request against 1.3.0 solves the problem for us.

            markewaite Mark Waite added a comment -

            Johannes confirmed that 1.3.0 resolves the issue for him.

            markewaite Mark Waite added a comment -

            Johannes verification was done with a released version of the plugin, so no further work remains.

            languitar Johannes Wienke added a comment -

            Wait, I think this is a misunderstanding. 1.3.0 does not solve the problem as it is release right now. We took 1.3.0 from git and applied the pull request on this and THEN the problem is solved.

            markewaite Mark Waite added a comment -

            Thanks for the clarification. I believe the git plugin maintainer has merged a different solution for the same problem to the tip of the current git plugin code. I assume that will be part of git plugin 1.4.0.

            Refer to https://github.com/jenkinsci/git-plugin/commit/2dd62deb994f99304b4edcf94c40e504f2f61876 for the details of the change that has been merged.

            languitar Johannes Wienke added a comment -

            Actually we also tried to use the recent master version, but that plugin wasn't recognized correctly by our jenkins installation. So we didn't continue to investigate in that direction.

            markewaite Mark Waite added a comment -

            When I used the Jenkins master version, it did not work in the case I tested. However, I can't explain why it did not work, since it included the same change as the version which worked for you. I think we may need to rely on Nicolas De Loof to fix it.

            When I checked out the Jenkins master version, I was surprised to see that the two unit tests which had been added to test the fix were also failing. That may indicate that Nicolas is not yet ready to release the fix for this problem officially.


              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                languitar Johannes Wienke
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: