Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18272

Expose key maven properties (such as GAV IDs) as build variables

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      ... so that one can use it as variables in the post-build actions.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi created issue -
            christoe Christoffer Kylvåg added a comment -

            Pull request containing a possible solution to this here: https://github.com/jenkinsci/jenkins/pull/933

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            src/main/java/hudson/maven/MavenModule.java
            src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/maven-plugin/59afb8b94eade3b29de98103d914ec487c128814
            Log:
            [FIXED JENKINS-18272]

            Expose various key properties of POM as environment variables.

            scm_issue_link SCM/JIRA link daemon made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            kutzi kutzi added a comment -

            Is a new feature and not a bug

            kutzi kutzi made changes -
            Issue Type Bug [ 1 ] New Feature [ 2 ]
            mmchr Mads Mohr Christensen made changes -
            Link This issue is related to JENKINS-20594 [ JENKINS-20594 ]
            jglick Jesse Glick made changes -
            Link This issue depends on JENKINS-21279 [ JENKINS-21279 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 149578 ] JNJira + In-Review [ 193190 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                kohsuke Kohsuke Kawaguchi
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: