Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18470

Jenkins Jobs are not displayed after CVS Plugin Downgrade

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.516, Redhat 5.6 64Bit, Tomcat 6,
    • Similar Issues:

      Description

      To reproduce:
      1. Install Jenkins 1.516 which comes with bundled CVS Plugin 2.8
      2. create a maven job using a CVS SCM and save it
      3. downgrade CVS plugin to 1.6
      4. restart jenkins

      Result: the job neither isnt't available in the "all" view, nor cant it be displayed by opening a bookmark with the job URL

      Expected: job is displayed at least in "all" view and can be called directly by using the job name URL, at least with an error message about non-supported plugin-data in the job

      Workaround: remove the <scm> section from config.xml and restart Jenkinks and configure CVS with the previous values

      In the log there a are lot of plugin-releated error messages:
      Jun 23, 2013 11:12:46 AM hudson.util.RobustReflectionConverter doUnmarshal
      WARNING: Skipping a non-existent field repositories
      com.thoughtworks.xstream.converters.reflection.MissingFieldException: No field 'repositories' found in class 'hudson.scm.CVSSCM'
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.field(FieldDictionary.java:94)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.getFieldType(PureJavaReflectionProvider.java:157)
      at hudson.util.RobustReflectionConverter.determineType(RobustReflectionConverter.java:399)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:271)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:333)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:275)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1061)
      at hudson.util.XStream2.unmarshal(XStream2.java:109)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1045)
      at com.thoughtworks.xstream.XStream.fromXML(XStream.java:925)
      at hudson.XmlFile.read(XmlFile.java:143)
      at hudson.model.Items.load(Items.java:220)
      at jenkins.model.Jenkins$17.run(Jenkins.java:2542)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:893)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Jun 23, 2013 11:12:46 AM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading job uniqa-aura
      hudson.util.IOException2: Unable to read /var/hudson/jobs/uniqa-aura/config.xml
      at hudson.XmlFile.read(XmlFile.java:147)
      at hudson.model.Items.load(Items.java:220)
      at jenkins.model.Jenkins$17.run(Jenkins.java:2542)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:893)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: Could not set field class hudson.scm.CVSSCM.skipChangeLog : null : Could not set field class hudson.scm.CVSSCM.skipChangeLog : null
      ---- Debugging information ----
      message : Could not set field class hudson.scm.CVSSCM.skipChangeLog : null
      cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
      cause-message : Could not set field class hudson.scm.CVSSCM.skipChangeLog : null
      class : hudson.scm.CVSSCM
      required-type : hudson.scm.CVSSCM
      converter-type : hudson.util.RobustReflectionConverter
      path : /maven2-moduleset/scm/skipChangeLog
      line number : 54
      class[1] : hudson.maven.MavenModuleSet
      version : null
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:79)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:333)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:275)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1061)
      at hudson.util.XStream2.unmarshal(XStream2.java:109)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1045)
      at com.thoughtworks.xstream.XStream.fromXML(XStream.java:925)
      at hudson.XmlFile.read(XmlFile.java:143)
      ... 10 more
      Caused by: com.thoughtworks.xstream.converters.reflection.ObjectAccessException: Could not set field class hudson.scm.CVSSCM.skipChangeLog : null
      at com.thoughtworks.xstream.converters.reflection.Sun14ReflectionProvider.write(Sun14ReflectionProvider.java:141)
      at com.thoughtworks.xstream.converters.reflection.Sun14ReflectionProvider.writeField(Sun14ReflectionProvider.java:104)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:290)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      ... 26 more
      Caused by: java.lang.IllegalArgumentException
      at sun.misc.Unsafe.objectFieldOffset(Native Method)
      at com.thoughtworks.xstream.converters.reflection.Sun14ReflectionProvider.getFieldOffset(Sun14ReflectionProvider.java:150)
      at com.thoughtworks.xstream.converters.reflection.Sun14ReflectionProvider.write(Sun14ReflectionProvider.java:112)
      ... 30 more

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Downgrading plugins (across major versions even!) is not a supported use case.

          That being said, newer Jenkins versions massively improved robustness when deserializing jobs (JENKINS-21024, JENKINS-22398). Therefore I'm closing this as Cannot Reproduce. Feel free to reopen if you can show this still occurs in 1.558+.

          skybird Florian Rosenauer added a comment -

          Thanks, its fine for me.
          We are currently using a sticky revision of CVS 1.6 Plugin (because of JENKINS-18539) so it shouldn't happen on our installation again.


            People

            • Assignee:
              Unassigned
              Reporter:
              skybird Florian Rosenauer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: