Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18551

Coverity Plugin Is Incompatible with MSBuild Plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: coverity-plugin
    • Environment:
      Windows Server 2008, Java 1.6.0_43, Jenkins 1.517, Coverity Plugin 1.2.3, MSBuild Plugin 1.16
    • Similar Issues:

      Description

      Coverity works with MSBuild only when the user creates their own MSBuild script via a "Execute Windows batch command" build step and executes the following command:

      [Builds] $ C:\Coverity\CIC\static-analysis\bin\cov-build --dir C:\CoverityAnalyzeDir cmd /c call C:\Temp\hudson56334.bat

      However, if someone attempts to run Coverity with the MSBuild plugin which has environment variables in it, the following command gets executed and an error occurs:

      [JENKINS_COVERITY_TEST] $ C:\Coverity\CIC\static-analysis\bin\cov-build --dir C:\CoverityAnalyzeDir cmd.exe /C C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe /t:Clean;Build /nologo /p:Configuration=Release %BUILD_DIRECTORY%\Project.sln && EXIT %%ERRORLEVEL%%
      The filename, directory name, or volume label syntax is incorrect.

        Attachments

          Issue Links

            Activity

            cwozny Chris Wozny added a comment -

            This issue probably is linked to the use of the Windows environment variables. Linking to issue 14833.

            cwozny Chris Wozny added a comment -

            This issue is probably caused by the use of Windows environment variables.

            jbriggs Joel Briggs added a comment -

            Resolving as Cannot Reproduce, issues JENKINS-38624/JENKINS-42308 were resolved in recent versions of the Coverity plugin.

            Please reopen if there's still an issue (or contact Synopsys (Coverity) support)


              People

              • Assignee:
                Unassigned
                Reporter:
                cwozny Chris Wozny
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: