Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18575

xUnit failed to parse a JUnit .xml report without any debug in log

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      jenkins core: 1.509.1
      xunit: 1.60
    • Similar Issues:

      Description

      "publish xUnit test report" post-build step constantly fails with such output:

      10:31:18 [xUnit] [INFO] - Starting to record.
      10:31:18 [xUnit] [INFO] - Processing JUnit
      10:31:19 [xUnit] [INFO] - [JUnit] - 3 test report file(s) were found with the pattern 'results-pjsip/*.xml' relative to '/tmp/workspace/_SIP/pjsip_c' for the testing framework 'JUnit'.
      10:31:20 [xUnit] [ERROR] - The result file '/tmp/workspace/_SIP/pjsip_c/results-pjsip/presence-tests-func-1372749982.89.xml' for the metric 'JUnit' is not valid. The result file has been skipped.
      10:31:20 [xUnit] [INFO] - Fail BUILD because 'set build failed if errors' option is activated.
      10:31:20 [xUnit] [INFO] - There are errors when processing test results.
      10:31:20 [xUnit] [INFO] - Skipping tests recording.
      10:31:20 [xUnit] [INFO] - Stop build.

      I have turned on the debug according to https://issues.jenkins-ci.org/browse/JENKINS-12900?focusedCommentId=159687&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-159687

      but unfortunately xUnit log contains only such records, which related to the other xUnit job, and not to failed one:

      Jul 2, 2013 8:44:39 AM com.thalesgroup.hudson.plugins.xunit.service.XUnitService infoSystemLogger
      INFO: [xUnit] - Converting '/var/lib/jenkins/jobs/SIP/jobs/b2bua_functest_report_cron/workspace/branch/mr30/results/TEST-test.ft8151_attended_transfer_basics-ft8151_attended_transf
      er_basics-ua2_wrong_user-1372743790288.xml' .

      Affected .xml report is in attachment.

      Please, prompt how I can get more verbose "parsing" log for this issue.

        Attachments

          Activity

          l_roche Louis Roché added a comment -

          I have the same problem after the upgrade of the plugin from 1.57 or 1.58 (I don't remember). Performance plugin read the file without problem.

          pitr Piotr Kral added a comment -
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Gregory Boissinot
          Path:
          src/main/java/org/jenkinsci/plugins/xunit/types/JUnitInputMetric.java
          src/main/java/org/jenkinsci/plugins/xunit/types/model/JUnit8.java
          src/main/resources/org/jenkinsci/plugins/xunit/types/model/xsd/junit-8.xsd
          http://jenkins-ci.org/commit/xunit-plugin/15da098793691c4d5a6b1a934a83587e4594643f
          Log:
          Fix JENKINS-18095 and JENKINS-18575

          Compare: https://github.com/jenkinsci/xunit-plugin/compare/88672e87da9f...15da09879369


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              vbaskoff Vitaliy Baskoff
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: