Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18973

Unable to create or upload script

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: scriptler-plugin
    • Labels:
      None
    • Environment:
      token-makro 1.8.1
      git-client 1.1.1
      git-plugin 1.4.0
      git-server 1.1
      scriptler 2.6.1
    • Similar Issues:

      Description

      Creating or uploading script causes java.lang.NoSuchMethodError: org.eclipse.jgit.storage.file.FileRepositoryBuilder.build()Lorg/eclipse/jgit/storage/file/FileRepository. The script is not saved.

      Discovered by selenium test suite[1].

      [1] https://jenkins.ci.cloudbees.com/job/selenium-tests/183/consoleFull

      Reproducing features:
      features/scriptler_plugin.feature:7 # Scenario: Run new script
      features/scriptler_plugin.feature:14 # Scenario: Run new parameterized script
      features/scriptler_plugin.feature:23 # Scenario: Delete script
      features/scriptler_plugin.feature:32 # Scenario: Run script on particular slave
      features/scriptler_plugin.feature:41 # Scenario: Run script on master
      features/scriptler_plugin.feature:50 # Scenario: Run script on all nodes
      features/scriptler_plugin.feature:59 # Scenario: Run script on all slaves
      features/scriptler_plugin.feature:70 # Scenario: Create and run parameterized test
      features/scriptler_plugin.feature:83 # Scenario: Override default parameters

        Attachments

          Activity

          mlasevich Michael Lasevich added a comment - - edited

          Yep, plugin not-functional with current jgit

          Update: I have another server with same versions of both git-server and scriptler which works fine. Upon comparing the two, I found that git-client was an older version (1.0.7) on the working server vs 1.1.1 on the one with this issue. I downgraded the server having a problem and it is working now.

          Hope this helps tracking this down.

          domi Dominik Bartholdi added a comment - - edited

          Yep, the issue is with the git-client plugin - I'm working on it, hope to have it fixed this weekend.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: imod
          Path:
          pom.xml
          src/main/java/org/jenkinsci/plugins/gitserver/ChannelTransport.java
          src/main/java/org/jenkinsci/plugins/gitserver/FileBackedHttpGitRepository.java
          http://jenkins-ci.org/commit/git-server-plugin/976e005c0d46e7c45b880a33afa9dadd18f2ff26
          Log:
          [FIXED JENKINS-18973] update jgit to same version as used by git-client

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          pom.xml
          src/main/java/org/jenkinsci/plugins/gitserver/ChannelTransport.java
          src/main/java/org/jenkinsci/plugins/gitserver/FileBackedHttpGitRepository.java
          http://jenkins-ci.org/commit/git-server-plugin/2ad2d233a42634fc86184599c11b64d28b186cab
          Log:
          Merge pull request #1 from imod/jgit-3.0

          [FIXED JENKINS-18973] update jgit to same version as used by git-client

          Compare: https://github.com/jenkinsci/git-server-plugin/compare/d19d6b160ea5...2ad2d233a426

          jglick Jesse Glick added a comment -

          In 1.2.


            People

            • Assignee:
              domi Dominik Bartholdi
              Reporter:
              olivergondza Oliver Gondža
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: