Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19031

com.thoughtworks.xstream.converters.ConversionException: Array index out of range: -1 : Array index out of range: -1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.525
    • Similar Issues:

      Description

      I tried to upgrade my test Jenkins instance from 1.480.3 to 1.525.

      On startup, I got this:

      org.jvnet.hudson.reactor.ReactorException: hudson.util.IOException2: Unable to read /var/lib/jenkins/config.xml
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:906)
      at jenkins.model.Jenkins.<init>(Jenkins.java:806)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:214)
      Caused by: hudson.util.IOException2: Unable to read /var/lib/jenkins/config.xml
      at hudson.XmlFile.unmarshal(XmlFile.java:170)
      at jenkins.model.Jenkins$17.run(Jenkins.java:2526)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:895)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:898)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:920)
      at java.lang.Thread.run(Thread.java:736)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: Array index out of range: -1 : Array index out of range: -1
      ---- Debugging information ----
      message : Array index out of range: -1
      cause-exception : java.lang.ArrayIndexOutOfBoundsException
      cause-message : Array index out of range: -1
      class : hudson.model.Hudson
      required-type : hudson.model.Hudson
      converter-type : hudson.util.RobustReflectionConverter
      path : /hudson/disabledAdministrativeMonitors
      line number : 3
      version : null
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:79)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1061)
      at hudson.util.XStream2.unmarshal(XStream2.java:109)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1045)
      at hudson.XmlFile.unmarshal(XmlFile.java:166)
      ... 9 more
      Caused by: java.lang.ArrayIndexOutOfBoundsException: Array index out of range: -1
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.entrySet(OrderRetainingMap.java:77)
      at java.util.HashMap.putAllImpl(HashMap.java:678)
      at java.util.HashMap.putAll(HashMap.java:669)
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.<init>(OrderRetainingMap.java:36)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.buildMap(FieldDictionary.java:135)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.fieldOrNull(FieldDictionary.java:113)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.getFieldOrNull(PureJavaReflectionProvider.java:186)
      at hudson.util.RobustReflectionConverter.fieldDefinedInClass(RobustReflectionConverter.java:328)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:269)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      ... 18 more

        Attachments

          Issue Links

            Activity

            belpk K P added a comment -

            I assume this is now resolved by JENKINS-18537 ?

            danielbeck Daniel Beck added a comment -

            Should be fixed in 1.557 and 1.554.1 by this commit. If you're still experiencing this exact problem on these versions or newer, feel free to reopen.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Toomas Romer
            Path:
            pom.xml
            http://jenkins-ci.org/commit/cluster-stats/0824d108caac8778eb3ffa7a4591ca9d07d69c5b
            Log:
            Bumped dep to get it compiled wo missing com.github.jnr:jffi, bumped again JENKINS-19031

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Christoph Kutzinski
            Path:
            pom.xml
            http://jenkins-ci.org/commit/instant-messaging-parent-plugin/3c2666d51c523325621b025c4971232143a8b1f0
            Log:
            Update to Jenkins 1.565 because of JENKINS-19031

            thoni56 thoni56 added a comment -

            After updating to Windows 10 and a Java update I see this exact issue on Jenkins 1.633. I tried re-installing 1.633 but no change. What can I do to debug this further?


              People

              • Assignee:
                Unassigned
                Reporter:
                cjw296 Chris Withers
              • Votes:
                4 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: