Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: cvs-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      When a Project poll SCM (CVS) cause of changes,
      a exception will be triggered

      ERROR: Failed to record SCM polling for hudson.model.FreeStyleProject@44d044d[iUp]
      java.util.ConcurrentModificationException
      at java.util.AbstractList$SimpleListIterator.next(AbstractList.java:64)
      at hudson.scm.AbstractCvs.compareRemoteRevisionWith(AbstractCvs.java:469)
      at hudson.scm.CVSSCM.compareRemoteRevisionWith(CVSSCM.java:224)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      at hudson.scm.SCM.poll(SCM.java:373)
      at hudson.model.AbstractProject._poll(AbstractProject.java:1548)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1473)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:439)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:468)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:450)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:314)
      at java.util.concurrent.FutureTask.run(FutureTask.java:149)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:908)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:931)
      at java.lang.Thread.run(Thread.java:738)

      I'm using Jenkins version 1.525

        Attachments

          Issue Links

            Activity

            kosmaty Krzysztof Kosmatka added a comment -

              People

              • Assignee:
                mc1arke Michael Clarke
                Reporter:
                wiesel_j Julia
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: