Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: htmlpublisher-plugin
    • Labels:
      None
    • Environment:
      Debain 7 Linux luke-build 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux
    • Similar Issues:

      Description

      All htmlpublisher links no longer work.

      Relevant console output:
      [htmlpublisher] Archiving HTML reports...
      [htmlpublisher] Archiving at BUILD level /var/lib/jenkins/jobs/viper/workspace/build/api to /var/lib/jenkins/jobs/viper/builds/2013-09-03_18-31-39/htmlreports/API_Documentation
      [htmlpublisher] Archiving at BUILD level /var/lib/jenkins/jobs/viper/workspace/build/code-browser to /var/lib/jenkins/jobs/viper/builds/2013-09-03_18-31-39/htmlreports/Code_Browser
      [htmlpublisher] Archiving at BUILD level /var/lib/jenkins/jobs/viper/workspace/build/jsdoc to /var/lib/jenkins/jobs/viper/builds/2013-09-03_18-31-39/htmlreports/JSDoc_API_Report

      Relevant chunk of config.xml:

      <htmlpublisher.HtmlPublisher plugin="htmlpublisher@1.2">
      <reportTargets>
      <htmlpublisher.HtmlPublisherTarget>
      <reportName>API Documentation</reportName>
      <reportDir>build/api/</reportDir>
      <reportFiles>index.xhtml</reportFiles>
      <keepAll>true</keepAll>
      <wrapperName>htmlpublisher-wrapper.html</wrapperName>
      </htmlpublisher.HtmlPublisherTarget>
      <htmlpublisher.HtmlPublisherTarget>
      <reportName>Code Browser</reportName>
      <reportDir>build/code-browser/</reportDir>
      <reportFiles>index.html</reportFiles>
      <keepAll>true</keepAll>
      <wrapperName>htmlpublisher-wrapper.html</wrapperName>
      </htmlpublisher.HtmlPublisherTarget>
      <htmlpublisher.HtmlPublisherTarget>
      <reportName>JSDoc API Report</reportName>
      <reportDir>build/jsdoc/</reportDir>
      <reportFiles>index.html</reportFiles>
      <keepAll>true</keepAll>
      <wrapperName>htmlpublisher-wrapper.html</wrapperName>
      </htmlpublisher.HtmlPublisherTarget>
      </reportTargets>
      </htmlpublisher.HtmlPublisher>

      All links in either the job or the build go to the appropriate URL which is now a "Status Code 404" page.

        Attachments

          Issue Links

            Activity

            mcrooney mcrooney added a comment -

            Thanks! This is a duplicate of https://issues.jenkins-ci.org/browse/JENKINS-19281, the fix should be out in 1.530.


              People

              • Assignee:
                mcrooney mcrooney
                Reporter:
                mythril lucas green
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: