Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19511

Cannot use configure on any job after upgrade

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows 2008 Server R2. Jenkins 1.529 exhibits this behavior. Upgraded from 1.499. Java 7u17
    • Similar Issues:

      Description

      Upgraded our Jenkins installation from 1.499 to 1.529. Jenkins configure screen for all our jobs now give a JavaScript error in Chrome and Firefox.

      I suspect it might be an issue as all our jobs have spaces in the name. In addition to this error, several of the optional plugins are trying to do validation when they are not enabled on the screen.

      Chrome error is:
      Uncaught SyntaxError: Unexpected token ILLEGAL hudson-behavior.js:416
      e.targetUrl hudson-behavior.js:416
      registerValidator hudson-behavior.js:428
      (anonymous function) behavior.js:111
      (anonymous function) behavior.js:107
      Behaviour.applySubtree behavior.js:93
      Behaviour.apply behavior.js:76
      (anonymous function) behavior.js:71
      window.onload behavior.js:125

      List of installed plugins:

      Ant Plugin
      This plugin adds Apache Ant support to Jenkins.
      1.2

      Audit Trail
      Keep a log of who performed particular Jenkins operations, such as configuring jobs.
      1.8
      Downgrade to 1.7

      Credentials Plugin
      This plugin allows you to store credentials in Jenkins.
      1.7.6
      Downgrade to 1.4
      Unpin

      External Monitor Job Type Plugin
      Adds the ability to monitor the result of externally executed jobs.
      1.2
      Downgrade to 1.1
      Unpin

      HTML5 Notifier Plugin
      The HTML5 Notifier Plugin provides W3C Web Notifications support for builds.
      1.2

      Hudson Copy Archiver Plug-in
      This plugin allows you upload using file protocol the archived artifacts into a shared directory. Only the artifacts of the latest build will be keept.
      0.5.1

      Hudson EasyAnt plugin
      This plugin allows Hudson to invoke EasyAnt build scripts directly.
      1.1

      Hudson GIT plugin
      This plugin integrates GIT with Hudson.
      2.1.0_1

      Hudson Post build task
      This plugin allows to execute a batch/shell task depending on the build log output.
      1.8
      Downgrade to 1.7

      Hudson PowerShell plugin
      This plugin allows Hudson to invoke Windows PowerShell as build scripts.
      1.2

      Hudson Ruby Plugin
      This plugin will let users use Ruby in the build scripts.
      1.2

      Hudson Seleniumhq plugin
      This plugin integrates Seleniumhq to Hudson.
      0.4

      Hudson Tray Application Plugin
      This plugin provides a Tray application that monitors this (and other) Hudson servers
      0.7.3

      Javadoc Plugin
      This plugin adds Javadoc support to Jenkins.
      1.1

      Jenkins Active Directory plugin
      This plugin enables authentication through Active Directory on Windows environment.
      1.33
      Downgrade to 1.33

      Jenkins CVS Plug-in
      Integrates Jenkins with CVS version control system using a modified version of the Netbeans cvsclient.
      2.9
      Downgrade to 2.7
      Unpin

      Jenkins Email Extension Plugin
      This plugin is a replacement for Jenkins's email publisher
      2.32
      Downgrade to 2.25

      Jenkins java.io.tmpdir cleaner plugin
      This plugin allows you to cleanup JVM temporary files.
      1.1

      Jenkins Mailer Plugin
      This plugin allows you to configure email notifications. This is a break-out of the original core based email component.
      1.5

      Jenkins MSBuild Plugin
      This plugin makes it possible to build a Visual Studio project (.proj) and solution files (.sln).
      1.20
      Downgrade to 1.16

      Jenkins Selenium Plugin
      This plugin turns your Jenkins cluster into a Selenium2 Grid cluster
      2.3
      Downgrade to 2.2

      Jenkins SSH plugin
      This plugin executes shell commands remotely using SSH protocol.
      2.3
      Downgrade to 1.2

      Jenkins Translation Assistance plugin
      This plugin adds an additional dialog box in every page, which enables people to contribute localizations for the messages they are seeing in the current page.
      1.10
      Downgrade to 1.8
      Unpin

      LDAP Plugin
      Security realm based on LDAP authentication.
      1.6
      Downgrade to 1.6
      Unpin

      Maven Integration plugin
      Special project type for Maven projects.
      1.529

      NAnt Plugin
      This plugin is a NAnt Builder for building .NET projects.
      1.4.3
      Downgrade to 1.4.1

      PAM Authentication plugin
      Adds Unix Pluggable Authentication Module (PAM) support to Jenkins.
      1.1
      Downgrade to 1.0
      Unpin

      Publish Over SSH
      Send build artifacts over SSH
      1.10
      Downgrade to 1.9

      SSH Credentials Plugin
      This plugin allows you to store SSH credentials in Jenkins.
      0.3

      SSH Slaves plugin
      This plugin allows you to manage slaves running on *nix machines over SSH.
      0.22
      Downgrade to 0.21
      Unpin

      Subversion Plugin
      This plugin adds the Subversion support (via SVNKit) to Jenkins.
      1.43
      Downgrade to 1.50

      SVN Publisher plugin
      This plugin allows you to upload artifacts to a subversion repository. This is done via a delete/import of the items requested.
      0.1

      Token Macro Plugin
      This plug-in adds reusable macro expansion capability for other plug-ins to use.

        Attachments

          Issue Links

            Activity

            lholt Lucas Holt added a comment -

            I've narrowed it down to one of the SSH plugins.

            schniedergers Klaus Schniedergers added a comment -

            Looks like a duplicate of JENKINS-19562?

            integer Kanstantsin Shautsou added a comment -

            Try update to latest version. Such things were fixed in newer versions.

            jglick Jesse Glick added a comment -

            Believed to have been resolved with the fix in JENKINS-19457.


              People

              • Assignee:
                Unassigned
                Reporter:
                lholt Lucas Holt
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: