Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1966

Selecting trac as repository browser with v1.6 of trac plugin causes exception when saving a build job.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: trac-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Trac plugin version 1.6
      Hudson version 1.229

      When I edit a job and select Trac as the Repository browser for a build, I get
      the error below when I try to save.

      Note: There is no error if just add the Trac url, and save. I will get the Trac
      link on the left side. However because I can't select Trac as the Repository
      browser and save without an error, our changes aren't decorated with links to
      the Trac source browser.

      HTTP Status 500 -

      type Exception report

      message

      description The server encountered an internal error () that prevented it from
      fulfilling this request.

      exception

      javax.servlet.ServletException: java.lang.AssertionError: class java.lang.String
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:449)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:254)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:361)
      org.kohsuke.stapler.Stapler.service(Stapler.java:121)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:38)
      hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:30)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52)
      hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)
      hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44)
      hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

      root cause

      java.lang.AssertionError: class java.lang.String
      hudson.scm.RepositoryBrowsers.createInstance(RepositoryBrowsers.java:80)
      hudson.scm.SubversionSCM$DescriptorImpl.newInstance(SubversionSCM.java:1033)
      hudson.scm.SubversionSCM$DescriptorImpl.newInstance(SubversionSCM.java:808)
      hudson.scm.SCMS.parseSCM(SCMS.java:37)
      hudson.model.AbstractProject.submit(AbstractProject.java:902)
      hudson.model.Project.submit(Project.java:144)
      hudson.model.FreeStyleProject.submit(FreeStyleProject.java:68)
      hudson.model.Job.doConfigSubmit(Job.java:830)
      hudson.model.AbstractProject.doConfigSubmit(AbstractProject.java:301)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:597)
      org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103)
      org.kohsuke.stapler.Function.bindAndinvoke(Function.java:57)
      org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:75)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:254)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:361)
      org.kohsuke.stapler.Stapler.service(Stapler.java:121)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:38)
      hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:30)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52)
      hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)
      hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42)
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44)
      hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

      note The full stack trace of the root cause is available in the
      JBossWeb/2.0.1.GA logs.

        Attachments

          Issue Links

            Activity

            jjv jjv added a comment -

            I have just tested this against the two previous versions the Trac plugin. I
            receive the stapler error shown in this issue with current Trac plugin as well
            as the previous two versions. I know that the 1.5 version of the Trac plugin
            worked previously. This suggests to me that something changed in the Hudson code
            itself that is causing this to break. I have noticed that there is a new entry
            in the repository browser list "auto" which I hadn't see before. In any case I
            believe the bug is in Hudson itself an not the Trac plugin.

            kohsuke Kohsuke Kawaguchi added a comment -

            A change in Hudson core broke this.
            Fix will require Hudson 1.232 + Trac 1.7.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/pom.xml
            trunk/hudson/main/core/src/main/java/hudson/PluginManager.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10585
            Log:
            JENKINS-1966 Stapler JSON binding needs to use uberClassLoader so that it can create instances from plugins.

            jjv jjv added a comment -

            Version 1.7 is not showing up as a download at:
            https://hudson.dev.java.net/servlets/ProjectDocumentList?folderID=6770&expandFolder=6770&folderID=0

            It's listed on the revision history though...

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 2051 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

              People

              • Assignee:
                Unassigned
                Reporter:
                jjv jjv
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: