Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1977

The second or more NAnt targets value setting problem.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: nant-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Windows XP
    • Similar Issues:

      Description

      The project has two or more NAnt build settings is not working properly.
      Becasuse the second or more NAnt targets value is set to the same value with the
      first NAnt targets.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/nant/src/main/java/hudson/plugins/nant/NantBuilder.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10571
            Log:
            [FIXED JENKINS-1977] Fixed in NAnt plugin 1.2.

            stevepov stevepov added a comment -

            How can I download Nant plugin 1.2? It says the issue is fixed, but there is
            nowhere to download the 1.2 version of the plugin. The page for the plugin just
            says fixed in upcoming version 1.2

            rajesh_sarva rajesh_sarva added a comment -

            I would like know when this issue can be fixed. using two or more NAnt build
            settings is very important for my project.

            Thanks
            Rajesh

            0johnw 0johnw added a comment -

            I've recently installed Hudson, in general I'm very impressed with it.

            Came searching for exactly this problem today. I can't believe what I'm reading here, surely there must be some misunderstanding? Fixed over a year ago, yet not available?

            What does it take to get this resolved, please?

            mdonohue mdonohue added a comment -

            You can get the latest successful build of the plugin here:
            http://hudson.glassfish.org/job/hudson/lastSuccessfulBuild/artifact/hudson/plugins/nant/target/

            If someone confirms the fix works in that build, I can do the release.

            0johnw 0johnw added a comment -

            Yes, it works, and I very much appreciate your effort Michael.

            I downloaded the nant.api from there, stopped our server,
            overwrote the one in the plugins directory and restarted.
            I now have 4 different nant scripts in one project, all
            working as I'd hoped. Many thanks.


              People

              • Assignee:
                Unassigned
                Reporter:
                yeoupooh yeoupooh
              • Votes:
                5 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: