Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20027

Exception thrown when Dashboard View plugin is not installed

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: m2release-plugin
    • Labels:
      None
    • Environment:
      Windows XP(SP2) x86
    • Similar Issues:

      Description

      Stack Trace :::

      WARNING: Failed to load org.jvnet.hudson.plugins.m2release.dashboard.RecentReleasesPortlet$DescriptorImpl
      java.lang.LinkageError: Failed to resolve class org.jvnet.hudson.plugins.m2release.dashboard.RecentReleasesPortlet$DescriptorIm
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule.resolve(ExtensionFinder.java:491)
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:524)
      at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:230)
      at com.google.inject.spi.Elements.getElements(Elements.java:103)
      at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:136)
      at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      at com.google.inject.Guice.createInjector(Guice.java:96)
      at com.google.inject.Guice.createInjector(Guice.java:73)
      at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:282)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:316)
      at hudson.ExtensionList.load(ExtensionList.java:295)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:309)
      at hudson.ExtensionList.load(ExtensionList.java:295)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      at hudson.ExtensionList.get(ExtensionList.java:153)
      at hudson.PluginManager$PluginUpdateMonitor.getInstance(PluginManager.java:1109)
      at hudson.maven.PluginImpl.init(PluginImpl.java:54)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:906)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.TypeNotPresentException: Type hudson.plugins.view.dashboard.DashboardPortlet not present
      at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(Unknown Source)
      at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      at sun.reflect.generics.visitor.Reifier.reifyTypeArguments(Unknown Source)
      at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      at sun.reflect.generics.repository.ClassRepository.getSuperclass(Unknown Source)
      at java.lang.Class.getGenericSuperclass(Unknown Source)
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule.resolve(ExtensionFinder.java:478)
      ... 41 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1315)
      at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1068)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Unknown Source)
      ... 50 more

        Attachments

          Issue Links

            Activity

            drekbour Marc Carter added a comment -

            Same here Jenkins 1.539 (on Solaris), M2Release 0.12.0

            maro_schutte Marcel Schutte added a comment -

            The M2 release plugin states (on the wiki, but also in its MANIFEST.MF) that is has an optional dependency on the dashboard view plugin.

            However, the above stacktrace is printed (during jenkins startup) when the dashboard plugin is not installed. Installing it prevents this.

            Please add an availability check before using code from optional dependencies. Changing the dependency to mandatory is also fine with me, but is of course the 'not so nice' option.

            mark3000 mark 3000 added a comment -

            Workaround. Installing the Dashboard View plugin suppressed these errors and reduced my startup time from 10 to 20 minutes to ~1 minute. Still testing.

            https://wiki.jenkins-ci.org/display/JENKINS/Dashboard+View

            ahammar Anders Hammar added a comment -

            Adjusted summary to reflect issue better.

            ahammar Anders Hammar added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Anders Hammar
            Path:
            src/main/java/org/jvnet/hudson/plugins/m2release/dashboard/RecentReleasesPortlet.java
            http://jenkins-ci.org/commit/m2release-plugin/6458233425d9f6f1231cdb1817b26fb06075fc3e
            Log:
            [FIXED JENKINS-20027] Exception thrown when Dashboard View plugin is not installed

            Signed-off-by: Anders Hammar <anders@hammar.net>

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: jtnord
            Path:
            src/main/java/org/jvnet/hudson/plugins/m2release/dashboard/RecentReleasesPortlet.java
            http://jenkins-ci.org/commit/m2release-plugin/7ee2284e0515ae0aeb784188c670de34c3b1f0c6
            Log:
            Merge pull request #23 from andham/JENKINS-20027

            [FIXED JENKINS-20027] Exception thrown when Dashboard View plugin is not...

            Compare: https://github.com/jenkinsci/m2release-plugin/compare/50bdcffd3dd2...7ee2284e0515


              People

              • Assignee:
                ahammar Anders Hammar
                Reporter:
                sairam Sairam Lakkoju
              • Votes:
                8 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: