Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20178

SSH Plugin unusable in jenkins versions 1.531 and 1.536

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ssh-plugin
    • Labels:
    • Environment:
      Ubuntu 12.04.3 LTS (GNU/Linux 3.5.0-40-generic x86_64)
    • Similar Issues:

      Description

      Using version 2.3 of the ssh plugin, with jenkins versions 1.531 or 1.536, the plugin throws the below error and the user interface elements are missing on the job configuration page. Previous jobs that have been setup to use the plugin display a blank area with a 'delete' button. The plugin appears to work in jenkins version 1.408.3

      Caused by: java.lang.AssertionError: class org.jvnet.hudson.plugins.SSHBuilder is missing its descriptor
      at jenkins.model.Jenkins.getDescriptorOrDie(Jenkins.java:1179)
      at hudson.tasks.Builder.getDescriptor(Builder.java:67)

        Attachments

          Activity

          Hide
          ljader Łukasz Jąder added a comment -

          Closing old bug - version 2.5 works on Jenkins LTS and weekly.

          Show
          ljader Łukasz Jąder added a comment - Closing old bug - version 2.5 works on Jenkins LTS and weekly.

            People

            • Assignee:
              Unassigned
              Reporter:
              jallen Jemma Allen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: