Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20257

Git plugin can't clone without a workspace

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.509.4
      Git plugin: 2.0
      git client plugin: 1.4.5
    • Similar Issues:

      Description

      I just upgraded to git plugin and Jenkins. I wiped out my workspace and then tried to run a build and got the messages below. I tried turning on the option to wipe out the workspace and force a clone and that didn't help either.

      15:56:31 Started by user Jon Schewe
      15:56:31 Building in workspace /home/hudson/.hudson/jobs/fll-release/workspace
      15:56:31 Pruning obsolete local branches
      15:56:31 FATAL: Command "config --get remote.origin.url" returned status code 1:
      15:56:31 stdout:
      15:56:31 stderr:
      15:56:31 hudson.plugins.git.GitException: Command "config --get remote.origin.url" returned status code 1:
      15:56:31 stdout:
      15:56:31 stderr:
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:940)
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:921)
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:865)
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:875)
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getRemoteUrl(CliGitAPIImpl.java:603)
      15:56:31 at hudson.plugins.git.GitAPI.getRemoteUrl(GitAPI.java:61)
      15:56:31 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.prune(CliGitAPIImpl.java:393)
      15:56:31 at hudson.plugins.git.extensions.impl.PruneStaleBranch.beforeCheckout(PruneStaleBranch.java:31)
      15:56:31 at hudson.plugins.git.GitSCM.checkout(GitSCM.java:858)
      15:56:31 at hudson.model.AbstractProject.checkout(AbstractProject.java:1376)
      15:56:31 at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:655)
      15:56:31 at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      15:56:31 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:560)
      15:56:31 at hudson.model.Run.execute(Run.java:1592)
      15:56:31 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      15:56:31 at hudson.model.ResourceController.execute(ResourceController.java:88)
      15:56:31 at hudson.model.Executor.run(Executor.java:237)

      Eventually I got my job to build, here is what I did.

      1) Delete configured repository
      2) Delete configured branches
      3) Select "None" as SCM
      4) Save
      5) Configure git repository

      Perhaps some data isn't getting properly migrated? I was running Jenkins 1.509.1 and git plugin 1.4.0 with git client plugin 1.4.5.

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                jpschewe jpschewe
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: