Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20279

Unable to manage job SVN credentials when deployed along Sonar on Tomcat.

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core, subversion-plugin
    • Environment:
    • Similar Issues:

      Description

      When deploying Jenkins along Sonar 3.7.2 in the same Tomcat server and using the following startup configuration (Which is required for Sonar to work on Tomcat):

      wrapper.java.additional.3=-Djruby.native.enabled=false

      The installation is a single master instance, with no slaves.
      We're getting an strange behaviour regarding the SVN credentials provision for each of the jobs, for some reason, we're getting a 403 Forbidden error even tough the credentials are fine and we're able to connect successfully to SVN via shell on the server.
      So basically, if we start any of the jobs we have, it won't be able to obtain the corresponding credentials for Subversion and will fail, I have attached the error for your reference.
      I've also tried deleting the subversion folder and even playing with several settings on the SVN server file.

      Here's the thing, if I deploy Jenkins alone, it'll work just fine.

      I'm suspecting this might be related to the fact that both Jenkins and Sonar are using JRuby, but since no further errors are being thrown I can't really tell much.

      I tried replicating this error in Windows to no avail, so it might be an environment related thing as well.

      Let me know if you need further information.

      Thanks!

        Attachments

          Activity

          Hide
          stephenconnolly Stephen Connolly added a comment -

          Can you confirm whether this issue is still present with the subversion plugin 2.x versions

          Show
          stephenconnolly Stephen Connolly added a comment - Can you confirm whether this issue is still present with the subversion plugin 2.x versions
          Hide
          ldse Alan Aguerreberre added a comment -

          Hello Stephen,
          Yes, I made an installation with the latest version of the plugin and was able to reproduce it in the said environment.

          Thanks for your response.

          Regards.

          Show
          ldse Alan Aguerreberre added a comment - Hello Stephen, Yes, I made an installation with the latest version of the plugin and was able to reproduce it in the said environment. Thanks for your response. Regards.
          Hide
          danielbeck Daniel Beck added a comment -

          Did you configure the credentials in Subversion plugin 2.x? If externals are involved, did you configure 'Additional Credentials' specifying an auth realm like shown on the command line?

          Show
          danielbeck Daniel Beck added a comment - Did you configure the credentials in Subversion plugin 2.x? If externals are involved, did you configure 'Additional Credentials' specifying an auth realm like shown on the command line?

            People

            • Assignee:
              Unassigned
              Reporter:
              ldse Alan Aguerreberre
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: