Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20316

I can't update plugins in updateCenter

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      jenkins 1.537 Red Hat Enterprise Linux Server release 5.7 (Tikanga)
    • Similar Issues:

      Description

      The network is ok, but when I update the plugins in updateCenter, I met following errors in jenkins log, could anybody help to check this? thx.

       
      Oct 29, 2013 4:38:10 PM org.eclipse.jetty.util.log.JavaUtilLog warn
      WARNING: /updateCenter/body
      org.apache.commons.jelly.JellyTagException: jar:file:/tmp/jetty-0.0.0.0-8080-jenkins.war--any-/webapp/WEB-INF/lib/jenkins-core-1.537.jar!/lib/layout/layout.jelly:75:72: <st:include> finished
              at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
              at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
              at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
              at org.apache.commons.jelly.tags.core.ForEachTag.doTag(ForEachTag.java:150)
              at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
              at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
              at org.apache.commons.jelly.tags.core.CoreTagLibrary$1.run(CoreTagLibrary.java:98)
              at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
              at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
              at org.kohsuke.stapler.jelly.CallTagLibScript.run(CallTagLibScript.java:120)
              at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
              at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
              at org.kohsuke.stapler.jelly.JellyViewScript.run(JellyViewScript.java:81)
              at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:63)
              at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:53)
              at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:95)
              at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:727)
              at org.kohsuke.stapler.Stapler.invoke(Stapler.java:841)
              at org.kohsuke.stapler.Stapler.invoke(Stapler.java:630)
              at hudson.init.impl.InstallUncaughtExceptionHandler$1.reportException(InstallUncaughtExceptionHandler.java:25)
              at org.kohsuke.stapler.compression.CompressionFilter.reportException(CompressionFilter.java:63)
              at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:49)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
              at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1474)
              at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:499)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
              at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:533)
              at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
              at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
              at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:428)
              at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
              at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
              at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
              at org.eclipse.jetty.server.Server.handle(Server.java:370)
              at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:489)
              at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:949)
              at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1011)
              at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
              at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
              at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:668)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
              at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: finished
              at com.jcraft.jzlib.DeflaterOutputStream.write(DeflaterOutputStream.java:90)
              at org.kohsuke.stapler.compression.FilterServletOutputStream.write(FilterServletOutputStream.java:31)
              at org.kohsuke.stapler.jelly.DefaultScriptInvoker$1.write(DefaultScriptInvoker.java:99)
              at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:202)
              at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:272)
              at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:276)
              at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:122)
              at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:212)
              at java.io.BufferedWriter.flush(BufferedWriter.java:236)
              at org.dom4j.io.XMLWriter.flush(XMLWriter.java:276)
              at org.apache.commons.jelly.XMLOutput.flush(XMLOutput.java:127)
              at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:271)
              ... 46 more
      

        Attachments

          Issue Links

            Activity

            dennys Dennys Hsieh added a comment -

            I have the same problem in 1.538, but not in update plugin. I'm not sure the pattern but just see lots of this warning message in log.

            dmaslakov Dmitry Maslakov added a comment -

            I met the same issue as Dennys described, a lot of messages in jenkins.log. Additionally, I've noted that this happens massively during Jenkins start and hugely delays start up time, currently I have it about 40 minutes.

            This is applicable to 1.537, 1.538, and 1.539.

            oleg_nenashev Oleg Nenashev added a comment -

            Duplicates JENKINS-20074


              People

              • Assignee:
                Unassigned
                Reporter:
                xiaopan3322 Bao Xiaopan(Bob)
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: