Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20512

Git Plugin 2.0: Failure on Git Polling Log when using option "Branches to build" on Git Plugin for Jenkins

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Jenkins version 1.509.4 on Windows 2008 R2
      Slave is running on Windows Server 2008 R2
      Jenkins GIT plugin v2.0
      Jenkins GIT client plugin v1.4.6
      GIT Client for Windows v1.8.4 (preview20130916)
    • Similar Issues:

      Description

      Hi,

      I am experiencing a problem on the GIT polling and here are the details:

      When the option "Branches to build" on GIT Plugin for Jenkins is "blank" or "**" the GIT polling working just fine but when I entered "master" or "origin/master" or other to option "Branches to build" the GIT polling crashes with the following error (see also snapshots):

      Started on Nov 11, 2013 1:15:13 PM
      Using strategy: Default
      [poll] Last Built Revision: Revision 1d530845b2467e9e342fbf19e101c1291e1458a9 (origin/master)
      FATAL: Error performing command: ls-remote -h ssh://git@mymachine0005.us.mycompany.com:7999/LT/ltpc.git master
      hudson.util.IOException2: Error performing command: ls-remote -h ssh://git@mymachine0005.us.mycompany.com:7999/LT/ltpc.git master
      at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:458)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      at hudson.scm.SCM.poll(SCM.java:373)
      at hudson.model.AbstractProject._poll(AbstractProject.java:1530)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1455)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:439)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:468)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: hudson.plugins.git.GitException: Error performing command: ls-remote -h ssh://git@mymachine0005.us.mycompany.com:7999/LT/ltpc.git master
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:988)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:920)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getHeadRev(CliGitAPIImpl.java:1297)
      at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:488)
      at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:456)
      ... 13 more
      Caused by: java.io.IOException: Cannot run program "git.exe": CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:773)
      at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:977)
      ... 17 more
      Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 23 more
      Done. Took 0.37 sec
      No changes

      Any Idea?

      Thank You for your support,
      Ronen.

        Attachments

          Activity

          maglovato Marco Lovato added a comment -

          I am reopening it since I am facing this, and the only fix I can do is rebooting Jenkins. Then everything starts to work again, for a while.

          Looks like a defect.

          Best
          Lovato

          maglovato Marco Lovato added a comment -

          Another interesting thing... when not works, I can see this line:

          at java.lang.UNIXProcess.<init>(UNIXProcess.java:164)

          Why I got an UNUXProcess error, if I am running it on a WinMachine? Does it make sense?

          Lovato

          markewaite Mark Waite added a comment -

          Marco Lovato I can't duplicate your bug report. The conditions you describe for your bug report seem quite different from the conditions on this bug report. This bug report failed consistently, while you said "the only fix I can do is rebooting Jenkins". I don't think reopening this bug report with an entirely new set of symptoms is the best way to handle the bug. Could you submit a new bug report rather than combining your very different set of symptoms with this bug report?

          When you submit the new bug report, could you also include information with the bug report confirming you've taken steps like the following:

          • Check the git installation on the master node
            • Define a job
            • Restrict the job to execute on the master node
            • Add the additional behaviour to force polling using workspace
            • Run "git --version" as a build step
            • Configure polling with some interval and verify it polls as expected
          • Check the git installation on the Linux slave
            • Define a job
            • Restrict the job to execute on the Linux slave
            • Add the additional behaviour to force polling using workspace
            • Run "git --version" as a build step
            • Configure polling with some interval and verify it polls as expected
          • Check the git installation on the windows slave
            • Define a job
            • Restrict the job to execute on the windows slave
            • Add the additional behaviour to force polling using workspace
            • Run "git --version" as a build step
            • Configure polling with some interval and verify it polls as expected

          That output will help confirm that the git configuration in Jenkins is correct and that Jenkins can find git on the master and on each slave node when it starts.

          maglovato Marco Lovato added a comment -

          Ok. Tks for your attention on this.
          Created at https://issues.jenkins-ci.org/browse/JENKINS-23743

          Best
          Lovato

          markewaite Mark Waite added a comment -

          Fixed earlier, then reopened by Marco Lovato with a different bug. Closing it again


            People

            • Assignee:
              ronenpg Ronen Peleg
              Reporter:
              ronenpg Ronen Peleg
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: