Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20764

Failing upgrade from 1.533 to 1.541

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 13, Java 1.6
    • Similar Issues:

      Description

      I did system update to get jenkins upgraded
      `sudo apt-get upgrade jenkins
      sudo service jenkins stop
      sudo service jenkins start`

      Which resulted in (stacktrace bellow) looking at config file I seen that version field value did not changed from 1.533 to 1.541 ( I tried manually overwrite it but without success jenkins will fail again on start-up)

      hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.io.IOException: Unable to read /var/lib/jenkins/config.xml
      at hudson.WebAppMain$3.run(WebAppMain.java:234)
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.io.IOException: Unable to read /var/lib/jenkins/config.xml
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:907)
      at jenkins.model.Jenkins.<init>(Jenkins.java:806)
      at hudson.model.Hudson.<init>(Hudson.java:82)
      at hudson.model.Hudson.<init>(Hudson.java:78)
      at hudson.WebAppMain$3.run(WebAppMain.java:222)
      Caused by: java.io.IOException: Unable to read /var/lib/jenkins/config.xml
      at hudson.XmlFile.unmarshal(XmlFile.java:169)
      at jenkins.model.Jenkins$17.run(Jenkins.java:2541)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:896)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:744)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: -1 : -1
      ---- Debugging information ----
      message : -1
      cause-exception : java.lang.ArrayIndexOutOfBoundsException
      cause-message : -1
      class : hudson.model.Hudson
      required-type : hudson.model.Hudson
      converter-type : hudson.util.RobustReflectionConverter
      path : /hudson/disabledAdministrativeMonitors
      line number : 3
      version : not available
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:79)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1061)
      at hudson.util.XStream2.unmarshal(XStream2.java:109)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1045)
      at hudson.XmlFile.unmarshal(XmlFile.java:165)
      ... 9 more
      Caused by: java.lang.ArrayIndexOutOfBoundsException: -1
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.entrySet(OrderRetainingMap.java:77)
      at java.util.HashMap.putMapEntries(HashMap.java:511)
      at java.util.HashMap.putAll(HashMap.java:784)
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.<init>(OrderRetainingMap.java:36)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.buildMap(FieldDictionary.java:135)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.fieldOrNull(FieldDictionary.java:113)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.getFieldOrNull(PureJavaReflectionProvider.java:186)
      at hudson.util.RobustReflectionConverter.fieldDefinedInClass(RobustReflectionConverter.java:328)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:269)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:222)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
      ... 18 more

        Attachments

          Issue Links

            Activity

            007g3m1n1 Gemini A added a comment -

            possibly related to breakage in v1.540 carrying over to v1.541

            peter_budo Peter Miklosko added a comment -

            So is there any easy way to fix it?

            007g3m1n1 Gemini A added a comment -

            Hi Peter, I think 1.539 works. http://mirrors.jenkins-ci.org/war/1.539/
            Try that for now until Jenkins is able to release a working build.

            peter_budo Peter Miklosko added a comment -

            Thanks Gemini, but I guess I will have to wait for next release since I do not use war but system driven updates

            hanxue_dev Hanxue Lee added a comment -

            This problem still happens when I upgrade from 1.541 to 1.544 . If it helps, I am using OS X 10.9 Java 1.7.0_40-b43

            dmodoomsirius dmodoom sirius added a comment -

            having the same issue on Jenkins ver. 1.566. any clues?

            donaldduck37 Tilakraj Moger added a comment -

            Hi Everybody,

            i am new to jenkins, even i am getting same error after i unpin and downgraded some of the jenkins plugins, please help me!
            hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.io.IOException: Unable to read C:\Tools\jenkins\config.xml
            at hudson.WebAppMain$3.run(WebAppMain.java:237)
            Caused by: org.jvnet.hudson.reactor.ReactorException: java.io.IOException: Unable to read C:\Tools\jenkins\config.xml
            at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
            at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
            at jenkins.model.Jenkins.executeReactor(Jenkins.java:924)
            at jenkins.model.Jenkins.<init>(Jenkins.java:816)
            at hudson.model.Hudson.<init>(Hudson.java:85)
            at hudson.model.Hudson.<init>(Hudson.java:81)
            at hudson.WebAppMain$3.run(WebAppMain.java:225)
            Caused by: java.io.IOException: Unable to read C:\Tools\jenkins\config.xml
            at hudson.XmlFile.unmarshal(XmlFile.java:165)
            at jenkins.model.Jenkins$17.run(Jenkins.java:2687)
            at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
            at jenkins.model.Jenkins$8.runTask(Jenkins.java:913)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
            Caused by: jenkins.util.xstream.CriticalXStreamException: hudson.plugins.active_directory.ActiveDirectorySecurityRealm : hudson.plugins.active_directory.ActiveDirectorySecurityRealm
            ---- Debugging information ----
            message : hudson.plugins.active_directory.ActiveDirectorySecurityRealm
            cause-exception : com.thoughtworks.xstream.mapper.CannotResolveClassException
            cause-message : hudson.plugins.active_directory.ActiveDirectorySecurityRealm
            class : hudson.model.Hudson
            required-type : hudson.model.Hudson
            converter-type : hudson.util.RobustReflectionConverter
            path : /hudson/securityRealm
            line number : 13
            version : not available
            -------------------------------
            at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:315)


              People

              • Assignee:
                Unassigned
                Reporter:
                peter_budo Peter Miklosko
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: