Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20841

Links of the pipeline view are not working for project using the Cloudbees folder plug-in

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I have a set of jobs inside a folder (using Cloudbees folder plug-in). I achieved to create a build pipeline view inside the folder that shows my jobs.

      All job related links of the pipeline view (link to job, to console or retry) fail in 404 error.

        Attachments

          Issue Links

            Activity

            Hide
            greydet Gonzague Reydet added a comment -

            Note that I made a pull request on github to fix this issue: https://github.com/jenkinsci/build-pipeline-plugin/pull/22

            Show
            greydet Gonzague Reydet added a comment - Note that I made a pull request on github to fix this issue: https://github.com/jenkinsci/build-pipeline-plugin/pull/22
            Hide
            dserodio Daniel Serodio added a comment -

            Gonzague's PR was merged and released in 1.4.3 but there are still some problems left (eg.: clicking on Run when the first job in the pipeline is parametrized gives a 404)

            Show
            dserodio Daniel Serodio added a comment - Gonzague's PR was merged and released in 1.4.3 but there are still some problems left (eg.: clicking on Run when the first job in the pipeline is parametrized gives a 404)
            Hide
            jeffastorey Jeff Storey added a comment -

            I created a patch for this issue for v1.4.3. I'm still looking into how to fix this for 1.4.4, but I'm yet sure what to do because JENKINS-25427 seems to have broken the run button for parameterized builds.

            My github branch for it is here - https://github.com/jeffastorey/build-pipeline-plugin/tree/jenkins_20841_v1.4.3_patch, but I can't create a pull request because of the 1.4.4 breakage mentioned above.

            Show
            jeffastorey Jeff Storey added a comment - I created a patch for this issue for v1.4.3. I'm still looking into how to fix this for 1.4.4, but I'm yet sure what to do because JENKINS-25427 seems to have broken the run button for parameterized builds. My github branch for it is here - https://github.com/jeffastorey/build-pipeline-plugin/tree/jenkins_20841_v1.4.3_patch , but I can't create a pull request because of the 1.4.4 breakage mentioned above.
            Hide
            jeffastorey Jeff Storey added a comment -
            Show
            jeffastorey Jeff Storey added a comment - Added a fix on master https://github.com/jenkinsci/build-pipeline-plugin/pull/56
            Hide
            integer Kanstantsin Shautsou added a comment -

            Released as 1.4.5 should appear on mirrors in the next 24h

            Show
            integer Kanstantsin Shautsou added a comment - Released as 1.4.5 should appear on mirrors in the next 24h

              People

              • Assignee:
                jeffastorey Jeff Storey
                Reporter:
                greydet Gonzague Reydet
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: