Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20848

Performance Plugin 1.9 happen OutOfMemoryError when had many data.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: performance-plugin
    • Labels:
    • Environment:
      Cent2.6, Jenkins1.536, Performance Plugin1.9, jtl files(JMeter2.4), Java1.6.0.22
    • Similar Issues:

      Description

      When opening a Performance Report page, Jenkins had no response.
      I could see OutOfMemoryError at log.

      *******
      Performance: Parsing JMeter report file 2013080300201824tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013080300201824tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Performance: Parsing JMeter report file 2013113016145321tracking_access_ssperf.jtl
      Exception in thread "RequestHandlerThread2" java.lang.OutOfMemoryError: Java heap space
      at java.util.LinkedList.addBefore(LinkedList.java:795)
      at java.util.LinkedList.add(LinkedList.java:215)
      at winstone.BoundedExecutorService.execute(BoundedExecutorService.java:62)
      at org.eclipse.jetty.util.thread.ExecutorThreadPool.dispatch(ExecutorThreadPool.java:126)
      at org.eclipse.jetty.server.nio.SelectChannelConnector$ConnectorSelectorManager.dispatch(SelectChannelConnector.java:300)
      at org.eclipse.jetty.io.nio.SelectorManager$SelectSet.doSelect(SelectorManager.java:708)
      at org.eclipse.jetty.io.nio.SelectorManager$1.run(SelectorManager.java:290)
      at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      Dec 3, 2013 11:16:38 AM hudson.triggers.SafeTimerTask run
      **********

      Jenkins memory setting
      JENKINS_JAVA_OPTIONS="-Djava.awt.headless=true -Dorg.apache.commons.jelly.tags.fmt.timeZone=Asia/Tokyo -Xmx2048m -XX:MaxPermSize=512m"

      This job's workspase has 147MB.(about 12files*11MB)
      I could not reproduce 1.7(other environment is same).

        Attachments

          Issue Links

            Activity

            guusdk Guus der Kinderen added a comment -

            I believe that the fix for JENKINS-26975 will also solve this issue.

            I would like to invite you to try the fix, which is available in this pull request: https://github.com/jenkinsci/performance-plugin/pull/44

            The automated pull request handler generated a new plugin here (this artifact might become unavailable in the future though): https://jenkins.ci.cloudbees.com/job/plugins/job/performance-plugin/78/org.jenkins-ci.plugins$performance/

            hitesh_22 Hitesh Patel added a comment -

            Reopen Jira if this is still an issue. Please provide sample files to help reproduce the issue.


              People

              • Assignee:
                manolo Manuel Carrasco
                Reporter:
                inomata naoto inomata
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: