Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20944

build metrics output should list real user

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: build-metrics-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 12.04 Server host
      WinXP/Win7/Ubuntu/Mac slaves
    • Similar Issues:

      Description

      On the build metrics output page under failed builds, the user column lists the user always as "SYSTEM" instead of the actual user that triggered the build. I could understand if the build was triggered that it might be listed as SYSTEM, although you probably still could determine who actually triggered it, but if an authenticated user initiated the build via the Jenkins interface, that user ID should be listed in the User column.

        Attachments

          Activity

          kerrhome Shannon Kerr added a comment -

          Any update on this?

          px3 Rolf Rother added a comment -

          Checking this

          px3 Rolf Rother added a comment -

          The User who triggered the build manually is allways shown correct.
          SYSTEM is for automated builds only.

          px3 Rolf Rother added a comment -

          Not a bug.


            People

            • Assignee:
              px3 Rolf Rother
              Reporter:
              kerrhome Shannon Kerr
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: