Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21018

After upgrading from v1.529 to any version later that v1.542 and then updating any plugin, jenkins becomes unsusable.

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      MS Windows Server Datacenter 2012 x64
    • Similar Issues:

      Description

      Originally reported in https://issues.jenkins-ci.org/browse/JENKINS-20630, then moved here.

      Linards L added a comment - 03/Dec/13 11:33 AM - edited
      Still not fully functional. Reverted to v1.529.
      After first upgrade from v1.529 - it booted. After I updated more than 10 plugins and restarted ( second time, no jobs were finished / launched ) jenkins with v1.542, it again died with Jetty issues / spam in logs.
      My updated plugins:
      Artifactory Plugin
      This plugin allows deploying Maven 2, Maven 3, Ivy and Gradle artifacts and build info to the Artifactory artifacts manager.
      2.2.1 (2.1.7)
      Credentials Plugin
      This plugin allows you to store credentials in Jenkins.
      1.9.3 1.6
      CVS Plugin
      This bundled plugin integrates Jenkins with CVS version control system.
      2.11 2.9
      Disk Usage Plugin
      This plugin records disk usage.
      0.23 0.20
      HTML Publisher Plugin
      1.3 1.2
      JIRA Plugin
      This plugin integrates Atlassian JIRA to Jenkins.
      Brīdinājums: Šis spraudnis ir paredzēts Jenkins 1.533 un jaunākai versijai. Tas var gan strādāt, gan nestrādāt ar Jūsu Jenkins instalāciju.
      1.39 (1.36)
      JobConfigHistory Plugin
      Saves copies of all job and system configurations.
      2.5 2.4
      Maven Project Plugin
      Jenkins plugin for building Maven 2/3 jobs via a special project type.
      Brīdinājums: Šis spraudnis ir paredzēts Jenkins 1.532 un jaunākai versijai. Tas var gan strādāt, gan nestrādāt ar Jūsu Jenkins instalāciju.
      2.0 1.529
      Monitoring external jobs
      Adds the ability to monitor the result of externally executed jobs.
      1.2 1.1
      Nested View Plugin
      View type to allow grouping job views into multiple levels instead of one big list of tabs.
      1.14 1.10
      Parameterized Trigger Plugin
      This plugin lets you trigger new builds when your build has completed, with various ways of specifying parameters for the new build.
      2.21 2.20
      SSH Credentials Plugin
      This plugin allows you to store SSH credentials in Jenkins.
      Brīdinājums: Jaunā versija nav savietojama ar esošo uzstādīto spraudņa versiju. Jobs, kuri izmanto šo spraudni, var būt par iemeslu šo Jobu pārkonfigurācijai.
      1.6 0.3
      SSH Slaves plugin
      This plugin allows you to manage slaves running on *nix machines over SSH.
      Brīdinājums: Jaunā versija nav savietojama ar esošo uzstādīto spraudņa versiju. Jobs, kuri izmanto šo spraudni, var būt par iemeslu šo Jobu pārkonfigurācijai.
      1.5 0.25
      Subversion Plugin
      This plugin adds the Subversion support (via SVNKit) to Jenkins.
      1.54 1.51
      Warnings Plugin
      This plugin generates the trend report for compiler warnings in the console log or in log files.
      4.38 4.35

      cforce added a comment - 12/Dec/13 12:41 PM
      @Linards L Please post ur error logs. Did you test with Jenkins 1.543?

      Linards L added a comment - 13/Dec/13 12:31 PM - edited
      @cforce,
      I will do it now, but it will not be valid test anymore because once I reverted to v1.529, I updated plugins. So it might work now, but it does not cover the issue I had earlier - crash after second reboot ( after plugins update ).
      Test scenarion:
      1. Up and running jenkins v1.529 with master and three slaves; All slaves offline;
      2. Plugins - all updated ( from my last attempt ( see date of my previous comment here ));
      3. Creating a slave ; installing as windows service ; starting it - up and running;
      3.1 Updating java to 1.7u45 ;
      3.2 Cannot launch slave-agent.jnlp because previously FAILED installation left old jars in slave directory. I had to delete them to make slave-agent.jlpn connectable, so I could install it as service.
      4. Performing automatic upgrade with one job running and one in queue ; waiting till it finishes;
      Resulting in error from console before returning
      Finished: SUCCESS
      in console:
      ln builds\lastStableBuild c:\jenkins_master\jobs\trunk-build\lastStable failed
      java.nio.file.DirectoryNotEmptyException: c:\jenkins_master\jobs\trunk-ExportDlls\lastStable
      at sun.nio.fs.WindowsFileSystemProvider.implDelete(Unknown Source)
      at sun.nio.fs.AbstractFileSystemProvider.deleteIfExists(Unknown Source)
      at java.nio.file.Files.deleteIfExists(Unknown Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.Util.createSymlinkJava7(Util.java:1146)
      at hudson.Util.createSymlink(Util.java:1070)
      at hudson.model.AbstractBuild.createSymlink(AbstractBuild.java:494)
      at hudson.model.AbstractBuild.access$700(AbstractBuild.java:105)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:729)
      at hudson.model.Run.execute(Run.java:1628)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)
      5. Rebooting jenkins;
      6. Updating plugins, if available.
      Plugins to be updated:
      Credentials Plugin
      This plugin allows you to store credentials in Jenkins.
      1.9.4 1.9.3
      LDAP Plugin
      Security realm based on LDAP authentication.
      1.7 1.6
      Mailer
      This plugin allows you to configure email notifications. This is a break-out of the original core based email component.
      1.6 1.5
      Throttle Concurrent Builds Plugin
      This plugin allows for throttling the number of concurrent builds of a project running per node or globally.
      1.8.1 1.8
      7. Checking result...
      [!] Error

      hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.lang.NullPointerException
      at hudson.WebAppMain$3.run(WebAppMain.java:234)
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.lang.NullPointerException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:908)
      at jenkins.model.Jenkins.<init>(Jenkins.java:807)
      at hudson.model.Hudson.<init>(Hudson.java:82)
      at hudson.model.Hudson.<init>(Hudson.java:78)
      at hudson.WebAppMain$3.run(WebAppMain.java:222)
      Caused by: java.lang.NullPointerException
      at java.io.Reader.<init>(Unknown Source)
      at java.io.InputStreamReader.<init>(Unknown Source)
      at org.codehaus.groovy.runtime.DefaultGroovyMethods.getText(DefaultGroovyMethods.java:16092)
      at groovy.lang.GroovyShell$7.run(GroovyShell.java:714)
      at groovy.lang.GroovyShell$7.run(GroovyShell.java:711)
      at java.security.AccessController.doPrivileged(Native Method)
      at groovy.lang.GroovyShell.parse(GroovyShell.java:711)
      at groovy.lang.GroovyShell.parse(GroovyShell.java:790)
      at hudson.util.spring.BeanBuilder.parse(BeanBuilder.java:133)
      at hudson.security.SecurityRealm.createFilter(SecurityRealm.java:426)
      at hudson.security.HudsonFilter.reset(HudsonFilter.java:140)
      at jenkins.model.Jenkins.setSecurityRealm(Jenkins.java:2048)
      at jenkins.model.Jenkins$20.run(Jenkins.java:2631)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:897)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      jenkins.err: http://pastie.org/8550005
      I general, in each stage there was some small issues. This is definelty NOT fixed.

      Linards L added a comment - 15/Dec/13 6:47 PM - edited
      Repeated update process.
      Now only updatable plugin was:
      Parameterized Trigger Plugin
      This plugin lets you trigger new builds when your build has completed, with various ways of specifying parameters for the new build.
      2.22 2.21
      Result is the same. First reboot is ok. Second - after updating plugin - total crash. Again back to v1.529.

        Attachments

          Issue Links

            Activity

            the_owl_eye E Tauro added a comment - - edited

            Even 1.529 has failures using Tomcat 7 as windows service!
            Managed to use the stable version 1.532.1 for windows and used the MSI to do an install and re-created a few jobs, this version is thus far working fine.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            core/src/main/java/hudson/util/spring/BeanBuilder.java
            http://jenkins-ci.org/commit/jenkins/5f06dfe852075e1daeac823352004c22a3cd2510
            Log:
            JENKINS-21018

            Being defensive.

            kohsuke Kohsuke Kawaguchi added a comment -

            It's failing to find /WEB-INF/security/SecurityFilters.groovy, which suggests this is a failure mode of JENKINS-22442

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #3270
            JENKINS-21018 (Revision 5f06dfe852075e1daeac823352004c22a3cd2510)

            Result = SUCCESS
            kohsuke : 5f06dfe852075e1daeac823352004c22a3cd2510
            Files :

            • core/src/main/java/hudson/util/spring/BeanBuilder.java

              People

              • Assignee:
                Unassigned
                Reporter:
                hx_unbanned Linards L
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: